<!DOCTYPE html>
<html class="no-js" itemscope itemtype="http://schema.org/WebPage" lang="en" prefix="og: http://ogp.me/ns#">
<head>
<meta http-equiv="Content-Type" content="text/html;charset=utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"30b3ffac80","applicationID":"29725091","transactionName":"dAwPFRELDlhUFBpDQkRMEQAEAREbQg5aQ21WERUIAAgH","queueTime":0,"applicationTime":1382,"agent":""}</script>
<script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="format-detection" content="telephone=no" />
<meta name="HandheldFriendly" content="True" />
<meta http-equiv="Content-Style-Type" content="text/css" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<meta name="google-site-verification" content="Q6-HYgph0PP5v8F5bD1wZ1Z8Pcg2QQd47eiwnlJ07NU" />
<title>WhatsApp hack allowed surveillance of key users of Facebook&#39;s &#39;secure&#39; chat app</title>
<meta name="description" content="WhatsApp hack allowed surveillance of key users of Facebook&#39;s &#39;secure&#39; chat app" />
<meta name="keywords" content="Security, Privacy , Hacking, Facebook, whatsapp" />

<meta name="DCSext.topics" content="security;privacy;hacking;facebook;whatsapp" />

<link rel="canonical" href="https://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack" />
<link rel="syndication-source" href="https://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack" />
<link rel="original-source" href="https://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack" />
<meta property="article:modified_time" content="2019-05-14T10:44:48+01:00" />
<meta property="article:published_time" content="2019-05-14T10:44:00+01:00" />
<meta name="news_keywords" content="Security ,Security,Privacy ,Hacking,Facebook,whatsapp" />
<meta http-equiv="Set-Cookie" content="last_page_viewed=https://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack;path=/;expires=2019-05-16 14:10:23 +0100;domain=.theinquirer.net;" />
<meta http-equiv="Set-Cookie" content="last_visited_page=/inquirer/news/3075717/whatsapp-spyware-hack;path=/;expires=2019-05-16 14:10:23 +0100;domain=.theinquirer.net;">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon.png" rel="apple-touch-icon" sizes="57x57">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon-76x76.png" rel="apple-touch-icon" sizes="76x76">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180">
<link href="https://www.theinquirer.net/images/favicons/icon-hires.png?0456789" rel="icon" sizes="192x192">
<link href="https://www.theinquirer.net/images/favicons/icon-normal.png?0456785" rel="icon" sizes="128x128">
<link href="https://www.theinquirer.net/images/favicons/32x32.ico" rel="shortcut icon" type="image/png">
<meta name="msapplication-TileImage" content="https://www.theinquirer.net/images/favicons/mstile-144x144.png?100518">
<meta name="msapplication-TileColor" content="#fd1d01">
<meta property="og:title" content="WhatsApp hack allowed surveillance of key users of Facebook&#39;s &#39;secure&#39; chat app | TheINQUIRER " />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack" />
<meta property="og:image" content="http://www.theinquirer.net/w-images/fa8d1546-5fcb-4543-ac50-a2ec2918db9b/1/whatsapplogoonsmartphone-370x229.jpeg" />
<meta property="og:site_name" content="http://www.theinquirer.net" />
<meta property="og:description" content="Freedom of speech privacy just got kicked in the nads,Security ,Security,Privacy ,Hacking,Facebook,whatsapp" " />
<meta name="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="INQ" />
<meta name="twitter:domain" content="//www.theinquirer.net/">
<meta property="twitter:creator" content="ChrisTheDJ" />
<meta property="twitter:url" content="https://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack" />
<meta property="twitter:image" content="http://www.theinquirer.net/w-images/fa8d1546-5fcb-4543-ac50-a2ec2918db9b/1/whatsapplogoonsmartphone-370x229.jpeg" />
<meta property="twitter:description" content="Freedom of speech privacy just got kicked in the nads" />
<meta itemprop="name" content="WhatsApp hack allowed surveillance of key users of Facebook&#39;s &#39;secure&#39; chat app | TheINQUIRER" />
<meta itemprop="description" content="Freedom of speech privacy just got kicked in the nads,Security ,Security,Privacy ,Hacking,Facebook,whatsapp" />
<meta itemprop="image" content="http://www.theinquirer.net/w-images/fa8d1546-5fcb-4543-ac50-a2ec2918db9b/1/whatsapplogoonsmartphone-370x229.jpeg" />
<link href="//assets.theinquirer.net/cdn/inq/styles/styles.css" media="all" rel="stylesheet" type="text/css">
<!--[if lt IE 9]>
		<script src="http://assets.theinquirer.net/cdn/global/scripts/html5shiv.js"></script>
		<link href="http://assets.theinquirer.net/respond-proxy.html" id="respond-proxy" rel="respond-proxy" />
		<link href="/images/respond.proxy.gif" id="respond-redirect" rel="respond-redirect" />
		<![endif]-->
<!--[if lt IE 9]>
        	<script src="http://assets.theinquirer.net/cdn/global/scripts/respond.js"></script>
           	<script src="/javascripts/respond.proxy.js"></script>
		<![endif]-->
<script src="//assets.theinquirer.net/cdn/global/scripts/jquery_1-11-2.min.js"></script>


<script type="text/javascript" language="Javascript">
universal_variable_string = '{ "content": { "article":"news", "source":"inquirer", "author":"chris-merriman", "medium":"text", "published":"2019-05-14T10:44:00+01:00", "tag":["security","privacy","hacking","facebook","whatsapp"], "image":"/w-images/fa8d1546-5fcb-4543-ac50-a2ec2918db9b/1/whatsapplogoonsmartphone-185x114.jpeg", "restriction":"default","barrier":"free"}, "page": { "url": "https://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack", "title": "WhatsApp hack allowed surveillance of key users of Facebook&amp;#39;s &amp;#39;secure&amp;#39; chat app", "description": "Freedom of speech privacy just got kicked in the nads", "type": "article", "category": "security", "parentcategory": "communications", "id": "3075717", "environment": "live", "site":"theinquirer.net", "platform":"desktop"} }';
</script>

<script type="text/javascript" src='//assets.theinquirer.net/javascript/live/the_inquirer/javascript-the_inquirer.head.min.js'></script>

<script>
		(function(H){H.className=H.className.replace(/\bno-js\b/,'')})(document.documentElement);
		
		  !function(){"use strict";function e(e,t,s){e.addEventListener?e.addEventListener(t,s,!1):e.attachEvent&&e.attachEvent("on"+t,s)}function t(e){return window.localStorage&&localStorage.font_css_cache&&localStorage.font_css_cache_file===e}function s(){if(window.localStorage&&window.XMLHttpRequest)if(t(n))c(localStorage.font_css_cache);else{var e=new XMLHttpRequest;e.open("GET",n,!0),e.onreadystatechange=function(){4===e.readyState&&200===e.status&&(c(e.responseText),localStorage.font_css_cache=e.responseText,localStorage.font_css_cache_file=n)},e.send()}else{var s=document.createElement("link");s.href=n,s.rel="stylesheet",s.type="text/css",document.getElementsByTagName("head")[0].appendChild(s),document.cookie="font_css_cache"}}function c(e){var t=document.createElement("style");t.setAttribute("type","text/css"),document.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var n="//assets.theinquirer.net/cdn/inq/styles/fonts/sourcesanspro.css?ver=1";window.localStorage&&localStorage.font_css_cache||document.cookie.indexOf("font_css_cache")>-1?s():e(window,"load",s)}();
		</script>
<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({article:'auto'});
	  !function (e, f, u) {
	    e.async = 1;
	    e.src = u;
	    f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/incisivemedia-theinquirer/loader.js');
	 </script>
<script>
        var _prum = [['id', '58fdbe6c837975e23a7862b3'],
        ['mark', 'firstbyte', (new Date()).getTime()]];
        (function() {
        var s = document.getElementsByTagName('script')[0]
        , p = document.createElement('script');
        p.async = 'async';
        p.src = '//rum-static.pingdom.net/prum.min.js';
        s.parentNode.insertBefore(p, s);
        })();
    </script>
</head>
<body class="article inquirer  ">
<div id="rdm-overlay" class="ad-slot-overlay"></div>
<div id="rdm-wallpaper" class="ad-slot-wallpaper"></div>
<div class="container">
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-above-header" class="ad-slot-full"></div>
</div>
</div>
</aside>
<div class="menu-sidebar">
<div class="menu-sidebar-inner">
<div class="search-3 header-search-holder blur">
<form id="search_form" action="/search" accept-charset="UTF-8" method="get">
<input type="submit" value="" aria-labelledby="Search" />
<span>
<input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
</span>
<input type="hidden" name="per_page" id="per_page" value="48" class="hidden_style" />
<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form> </div>
</div>
<nav class="mobile-nav">
<ul class="mobile-nav-ul">
<li class="active">
<div class="mobile-menu-title">
<a title="Home" href="/">Home</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="News" href="/type/news">News</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Artificial Intelligence" href="/tag/ai">Artificial Intelligence</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Internet of Things" href="/tag/iot">Internet of Things</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Open Source" href="/tag/open-source">Open Source</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Hardware" href="/category/hardware">Hardware</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Software" href="/category/software">Software</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Security" href="/tag/security">Security</a>
</div>
</li>
</ul>
</nav>
<div class="menu-sidebar-inner">
<ul class="sidebar-list">
<li>
<a href="//www.computing.co.uk/static/resources" target="_blank">Whitepapers</a>
</li>
<li>
<a href="/inquirer/content-hub/3030163/data-strategy-spotlight">Data Strategy Spotlight</a>
</li>
<li class="nav-tools newsletters">
<a href="http://email.theinquirer.net/k/Incisive-Business/inq_nlsuf" target="_blank">Newsletters</a>
</li>
</ul>
</div>
</div>
<nav class="main-top-nav">
<ul class="main-top-content main-top-menu content-width">
<li class="main-top-title main-top-tab-panel main-top-hound" id="hound">
<a href="//www.computing.co.uk/static/resources" target="_blank">Whitepapers</a>
<ul class="menu-top-panel">
<li>

<div class="section group content">
<div class="col span-lrg_4_of_5">
<section class="top-panel-paper">
<div class="image-text-group-a">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3546&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$"><img src="/w-images/250ff076-17cc-47ca-8825-3cbe7db5869c/1/inqlogo-120x194.jpeg" alt="Inqlogo 120x194" /></a>
</div>
<div class="image-text-group-b">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3546&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Five things you should look for in choosing a Testing provider</a>
<p>Choosing a Testing Partner can be complex.&nbsp; So what do you look for?&nbsp; This guide offers insight into the qualities you must look for in choosing a Testing provider.&nbsp; Download now to learn more.</p>
<a target="_blank" class="btn download" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3546&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Download</a>
</div>
</section>
<section class="top-panel-paper">
<div class="image-text-group-a">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=1654&amp;sid=$AMF_contact_id$-$AMF_contact_guid$"><img src="/w-images/59308cd1-dd2a-46a1-be10-c0728532bf56/1/inqlogo-120x194.jpeg" alt="Inqlogo 120x194" /></a>
</div>
<div class="image-text-group-b">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=1654&amp;sid=$AMF_contact_id$-$AMF_contact_guid$">Your questions answered: How to protect your data in the cloud</a>
<p>The number of successful cyberattacks per year per company has increased by 46% over the last four years. But what really needs to be considered when exploring a solution? What questions need to be asked? Download to find out...</p>
<a target="_blank" class="btn download" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=1654&amp;sid=$AMF_contact_id$-$AMF_contact_guid$">Download</a>
</div>
</section>
</div>
<div class="col span-lrg_1_of_5">
<section class="hound-search">
<header>
<div class="menu-top-panel-heading">Find whitepapers</div>
<div class="menu-top-panel-subheading">Search by title or subject area</div>
</header>
<aside>
<form target="_blank" name="multi" method="get" id="hound-search" enctype="multipart/form-data" action="//www.computing.co.uk/static/resources-search-results">
<input type="search" id="search-hound" placeholder="Search papers here" tabindex="1" required="" name="wpSearch">
<input type="hidden" value="theinquirer" name="publisher">
 <input type="submit" class="btn search-hound">
</form>
</aside>
</section>
<div class="panel-section-footer">
<div class="more-holder">
<a class="more-link" href="//www.computing.co.uk/static/resources" target="_blank">
<svg class="more-icon arrow-right" x="0" y="0" width="0.438em" height="0.938em">
<polygon points="0,3.553 3.947,7.5 0,11.447 0,14.5 7,7.5 0,0.5 "></polygon>
</svg>
View all whitepapers
</a>
</div>
</div>
</div>
</div>

</li>
</ul>
</li>
<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-sociallinks" id="follow" style="display:none;">
<a href="#">Follow us</a>
<ul class="header-tools-content">
<li>
<div class="nav-tools rss-icon">
<a href="//www.theinquirer.net/static/rss" target="_blank">RSS</a>
</div>
</li>
<li>
<div class="nav-tools twitter-icon">
<a href="//twitter.com/INQ" target="_blank">Twitter</a>
</div>
</li>
<li>
<div class="nav-tools linkedin">
<a href="//www.linkedin.com/showcase/the-inquirer" target="_blank">LinkedIn</a>
</div>
</li>
<li>
<div class="nav-tools newsletters">
<a href="http://email.theinquirer.net/k/Incisive-Business/inq_nlsuf" target="_blank">Newsletters</a>
</div>
</li>
<li>
<div class="nav-tools facebook-icon">
<a href="//www.facebook.com/pages/The-Inquirer/30395818327" target="_blank">Facebook</a>
</div>
</li>
<li>
<div class="nav-tools youtube">
<a href="//www.youtube.com/theinquirer" target="_blank">YouTube</a>
</div>
</li>
</ul>
</li>
<li class="main-top-title main-top-align-right main-top-tab-link main-top-register" id="register" style="display:none;">
<a href="http://email.theinquirer.net/k/Incisive-Business/inq_nlsuf" target="_blank">Newsletter</a>
</li>
<li class="main-top-title main-top-align-right main-top-user-status" id="rdm_header_user_status_link"></li>
<li class="main-top-title main-top-tab-link main-top-left02">
<a href="/tag/industry-voice">Industry Voice</a>
</li>
<li class="main-top-title main-top-tab-link main-top-left03">
<a href="/inquirer/content-hub/3030163/data-strategy-spotlight">Data Strategy Spotlight</a>
</li>
</ul>
</nav>
<header role="banner" class="main-head">
<div class="main-head-content content-width">
<div class="site-header">
<div class="site-logo-holder" itemscope itemtype="http://schema.org/Organization">
<div itemprop="name" class="screen-reader-text">
The Inquirer
</div>
<a href="/" title="Return to homepage" class="site-logo"> <img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="The Inquirer" class="sprite inquirer-logo"></a>
</div>
<div class="search-1 header-search-holder blur">
<form id="search_form_bottom" action="/search" accept-charset="UTF-8" method="get">
<input type="submit" value="" aria-labelledby="Search" />
<span>
<input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
</span>
<input type="hidden" name="per_page" id="per_page" value="48" class="hidden_style" />
<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form> </div>

</div>
</div>
</header>
<nav class="nav">
<div class="holder">
<div class="hamburger-style" id="nav-toggle" aria-label="Menu">
<span></span>
</div>
<script type="text/conditional-html" id="tablet-conditional-navigation">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</script>
<div id="conditional-navigation" class="">

<nav class="primary-nav nav-colour01" role="navigation" aria-label="Primary">
<ul class="main-menu main-top-content content-width">
<li class="menu-title">
<a title="Home" href="/">Home</a>
</li>
<li class="menu-title">
<a title="News" href="/type/news">News</a>
</li>
<li class="menu-title">
<a title="Artificial Intelligence" href="/tag/ai">Artificial Intelligence</a>
</li>
<li class="menu-title">
<a title="Internet of Things" href="/tag/iot">Internet of Things</a>
</li>
<li class="menu-title">
<a title="Open Source" href="/tag/open-source">Open Source</a>
</li>
<li class="menu-title">
<a title="Hardware" href="/category/hardware">Hardware</a>
</li>
<li class="menu-title">
<a title="Software" href="/category/software">Software</a>
</li>
<li class="menu-title">
<a title="Security" href="/tag/security">Security</a>
</li>
</ul>
</nav>
</div>
<div class="mobile-branding"><a href="/" class="mobile-branding-link" alt="The Inquirer"></a></div>
</div>
</nav>
<aside class="content">
<nav class="trendingbanner">
<ul>
<li>Trending</li>
<li><a title="OnePlus 7" href="https://www.theinquirer.net/inquirer/news/3069266/oneplus-7-release-date-specs-price-renders-notch">OnePlus 7 Pro</a></li>
<li><a title="ZombieLoad" href="https://www.theinquirer.net/inquirer/news/3075836/intel-zombieload-cpu-flaws">ZombieLoad</a></li>
<li><a title="Porn block" href="https://www.theinquirer.net/inquirer/news/3074319/uk-govs-porn-block-will-now-come-into-force-on-15-july">Porn block</a></li>
<li><a title="AMD Ryzen 3000" href="https://www.tweaktown.com/news/65054/amd-ryzen-3000-cpu-prices-teased-singaporean-retailer/index.html">AMD Ryzen 3000</a></li>
<li><a title="iPhone 11" href="https://www.theinquirer.net/inquirer/news/3066173/iphone-11-release-date-specs-price-reverse-wireless-charging">iPhone 11</a></li>
</ul>
</nav>
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-below-header" class="ad-slot-full"></div>
</div>
</div>
</aside>
<div class="page-content ajax_search">
<header class="article-header">
<div class="content">
<div class="content-inner">
<div class="main-content">
<div class="section group">
<div class="col span_1_of_5">
<img class="print-branding" src="//assets.theinquirer.net/cdn/inq/images/site-logo.png" alt="The Inquirer">
<nav>
<ul class="meta-taxonomy-list breadcrumb">
<li>
<a href="/category/communications/security/">Security</a>
</li>
</ul>
</nav>
</div>
<div class="col span_4_of_5">
<h1 itemprop="name" class="article-title">WhatsApp hack allowed surveillance of key users of Facebook&#39;s &#39;secure&#39; chat app</h1>
<h2 class="article-sub-title">Freedom of speech privacy just got kicked in the nads</h2>
</div>
</div>
</div>
</div>
</div>
</header>
<div class="content">
<main role="main" class="content-inner">
<div class="main-content">
<article class="section group article">
<div class="col span_1_of_5"></div>
<div class="col span_4_of_5 article-col">
<figure class="main">
<img alt="WhatsApp hack allowed surveillance of key users of Facebook&#39;s &#39;secure&#39; chat app" title="WhatsApp hack allowed surveillance of key users of Facebook&#39;s &#39;secure&#39; chat app" src="/w-images/fa8d1546-5fcb-4543-ac50-a2ec2918db9b/1/whatsapplogoonsmartphone-580x358.jpeg" />
<figcaption>
<div class="caption-text">
WhatsApp docked
</div>
</figcaption>
</figure>
<div id="rdm-below-summary"></div>
<div class="article-meta-container group">
<ul class="meta-taxonomy-list author-dateline ">
<li class="author-dateline-image">
<a title="Chris Merriman" href="/author/profile/2960/chris-merriman"><img class="author-pic" alt="Chris Merriman" src="/w-images/a44f6696-e74c-496c-a91e-c6a6fd3bd7cf/0/Picture13-100x100.jpg" /></a>
</li>
<li class="author-dateline-name">
<a href="/author/profile/2960/chris-merriman">Chris Merriman</a>
</li>
<li class="author-dateline-social">
<div class="meta-twitter">
<a class="twitter-follow" target="_blank" data-component="meta-twitter-handle" data-link-name="twitter-handle" href="https://twitter.com/ChrisTheDJ">
<svg viewBox="0 0 15 12" height="0.813em" width="0.938em" y="0" x="0" class="twitter-icon">
<path d="M15,1.422c-0.541,0.241-1.128,0.404-1.74,0.477c0.625-0.376,1.106-0.969,1.331-1.678
							c-0.584,0.347-1.235,0.602-1.924,0.737c-0.555-0.59-1.342-0.956-2.21-0.956c-1.675,0-3.03,1.354-3.03,3.028
							c0,0.236,0.027,0.468,0.077,0.692C4.986,3.594,2.756,2.39,1.262,0.556C1.001,1.002,0.851,1.522,0.851,2.078
							c0,1.051,0.536,1.977,1.348,2.521C1.702,4.582,1.237,4.446,0.828,4.222c0,0.013,0,0.025,0,0.037c0,1.467,1.043,2.691,2.429,2.971
							C3.003,7.297,2.735,7.334,2.459,7.334c-0.196,0-0.387-0.018-0.57-0.052c0.384,1.204,1.502,2.078,2.83,2.102
							c-1.035,0.813-2.343,1.299-3.76,1.299c-0.247,0-0.487-0.015-0.726-0.044C1.574,11.498,3.167,12,4.879,12
							c5.571,0,8.616-4.616,8.616-8.618c0-0.13,0-0.263-0.006-0.393C14.08,2.562,14.592,2.031,15,1.422z" />
</svg>
<div class="contact">
@ChrisTheDJ
</div>
</a>
</div>
</li>
<li class="author-dateline-time">
<time datetime="2019-05-14" itemprop="datePublished">
14 May 2019
</time>
</li>
</ul>
<div class="tools-meta-outer">
<ul class="tools-container">
<li>
<div title="Tweet" class="article-tools twitter-icon icons pos1">
<span title="Tweet" class="screen-reader-text">Tweet</span>
<a href="https://twitter.com/share?text=WhatsApp+hack+allowed+surveillance+of+key+users+of+Facebook%27s+%27secure%27+chat+app&amp;url=https://www.theinquirer.net/3075717/&via=inq" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Facebook" class="article-tools facebook-icon icons pos2">
<span class="screen-reader-text">Facebook</span>
<a href="https://www.facebook.com/sharer.php?u=https://www.theinquirer.net/3075717" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div data-social-tracking="added" title="Reddit" class="article-tools reddit-icon icons pos4">
<a href="https://reddit.com/submit?url=WhatsApp+hack+allowed+surveillance+of+key+users+of+Facebook%27s+%27secure%27+chat+app&amp;url=https://www.theinquirer.net/3075717" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div data-social-tracking="added" title="Stumbleupon" class="article-tools stumbleupon-icon icons pos5">
<a href="http://www.stumbleupon.com/submit?url=https://www.theinquirer.net/3075717" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>

<li>
<div title="Send to" class="article-tools email-icon icons pos6">
<span class="screen-reader-text">Send to</span>
<a target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#c1feb2b4a3aba4a2b5fc96a9a0b5b280b1b1e1a9a0a2aae1a0adadaeb6a4a5e1b2b4b3b7a4a8adada0afa2a4e1aea7e1aaa4b8e1b4b2a4b3b2e1aea7e187a0a2a4a3aeaeaae7a0acb1fae2f2f8fab2e1e7a0acb1fae2f2f8fab2a4a2b4b3a4e7a0acb1fae2f2f8fae1a2a9a0b5e1a0b1b1e7a0acb1faa3aea5b8fce4f185e4f180e4f185e4f180a9b5b5b1e4f280e4f387e4f387b6b6b6efb5a9a4a8afb0b4a8b3a4b3efafa4b5e4f387f2f1f6f4f6f0f6">&nbsp;</a>
</div>
</li>
</ul>

<div class="article-meta-numbers">
<div class="comment-count">
<a href="https://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack#disqus_thread">0 Comments</a>
</div>
<div class="social-count">
<a href="https://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack"><span class="share-total"></span></a>
</div>
</div>
</div>
</div>
<div class="article-page-body-content">

<p><strong>EVERYONE'S FAVOURITE DUMPSTER FIRE</strong>&nbsp;Facebook's<strong>&nbsp;</strong>'data breach of the week' goes to subsidiary WhatsApp, after it emerged that the company has inadvertently allowed hackers to install surveillance software on user's devices.</p>
<p>The company <a title="FT" href="https://www.ft.com/content/4da1117e-756c-11e9-be7d-6d846537acab" target="_blank" rel="noopener noreferrer">says</a> that the attack, which was first spotted earlier this month, affected a "select" group of&nbsp;and&nbsp;is the result of action from "an advanced cyber actor" (Max Headroom?).</p>
<p>The attackers were able to install spyware through WhatsApp's voice call function, even if the user did not pick up the call.</p>
<div id="rdm-above-related"></div>
<p>There's a very good chance that this was a State sanctioned hack, though which state isn't clear. However,&nbsp;<em>the FT</em> reports that the spyware was developed by Israel's NSO Group, <a title="Amnesty International staff targeted by Israeli-made 'Pegasus' spyware" href="https://www.theinquirer.net/inquirer/news/3036970/israeli-made-spyware-attempts-snooping-on-amnesty-international-through-whatsapp" target="_blank" rel="noopener noreferrer">whose&nbsp;Pegasus malware was previously used to target Amnesty International</a>.&nbsp;</p>

<p>People in the public eye - lawyers, activists, and anyone with a track record of speaking out on human rights - are the most likely targets, along with journalists.</p>
<p>As such, the <em>INQ</em> team have locked their phones in a Faraday Cage until all this blows over, as is clearly the rational course of action, though we suspect a band of grubby tech-hacks was not what the perpetrators had in mind.</p>
<p>"This attack has all the hallmarks of a private company known to work with governments to deliver spyware that reportedly takes over the functions of mobile phone operating systems," WhatsApp said in a statement to <em>the FT</em>.</p>
<p>"We have briefed a number of human rights organisations to share the information we can, and to work with them to notify civil society."</p>
<p>The revelation is particularly embarrassing for WhatsApp, which has built <a title="WhatsApp rolls out end-to-end encryption in light of Apple's FBI battle" href="https://www.theinquirer.net/inquirer/news/2453565/whatsapp-rolls-out-end-to-end-encryption-in-light-of-apples-fbi-battle" target="_blank" rel="noopener noreferrer">its entire business model on safe, secure, end-to-end encrypted messaging</a>.</p>
<p>The idea that someone could hack their way into viewing all those supposedly secure messages with what seems like relative ease is a big kick in the teeth, not just for users, but for the entire business model.</p>
<p>Facebook is currently working on <a title="Facebook to combine Instagram, WhatsApp and Messenger" href="https://www.theinquirer.net/inquirer/news/3069953/facebook-to-combine-instagram-whatsapp-and-messenger" target="_blank" rel="noopener noreferrer">bringing together the messaging platforms of Facebook (Messenger), Instagram and WhatsApp</a>, to give them all a commonality, cross-chat functionality and most importantly, end-to-end encryption. Early indications are that this will happen at the end of this year or the beginning of next.</p>
<p>It's quite plausible that this project allowed Facebook to spot the hack in the first place.</p>
<p>Facebook Towers has confirmed that a patch was rolled out last Friday before the press even got hold of the story. Still didn't contain it though, did it? Silly, silly Facebook.</p>
<p>The advice is simple - check your app store, if you have an update for WhatsApp waiting, for goodness sakes, install that bad boy. Like, now. &mu;</p>

<section class="further-reading">
<header>
<h4 itemprop="name">Further reading</h4>
</header>
<div class="section group">
<div class="col span_2_of_4">
<article>
<div class="listing-article-list-block">
<ul class="article-meta-above-title">
<li>
<a class="inquirer-link" href="/category/software/">Software</a>
</li>
</ul>
<div class="listings-article-title"><a title="iOS 13 mega-leak teases Dark Mode and WhatsApp-like Messages upgrade" href="/inquirer/news/3075164/ios-13-macos-15-watchos-6-leak">iOS 13 mega-leak teases Dark Mode and WhatsApp-like Messages upgrade</a></div>
<ul class="article-meta-details">
<li>
<time datetime="2019-05-07" itemprop="datePublished">
07 May 2019
</time>
</li>
</ul>
</div>
</article>
<article>
<div class="listing-article-list-block">
<ul class="article-meta-above-title">
<li>
<a class="inquirer-link" href="/category/software/">Software</a>
</li>
</ul>
<div class="listings-article-title"><a title="WhatsApp&#39;s Business app arrives on the iPhone " href="/inquirer/news/3072960/whatsapp-business-ios-release-official">WhatsApp&#39;s Business app arrives on the iPhone </a></div>
<ul class="article-meta-details">
<li>
<time datetime="2019-04-05" itemprop="datePublished">
05 Apr 2019
</time>
</li>
</ul>
</div>
</article>
</div>
<div class="col span_2_of_4">
<article>
<div class="listing-article-list-block">
<ul class="article-meta-above-title">
<li>
<a class="inquirer-link" href="/category/friction/controversy/">Controversy</a>
</li>
</ul>
<div class="listings-article-title"><a title="WhatsApp&#39;s co-founder Brian Acton still wants you to delete Facebook" href="/inquirer/news/3072682/whatsapps-co-founder-brian-acton-still-wants-you-to-delete-facebook">WhatsApp&#39;s co-founder Brian Acton still wants you to delete Facebook</a></div>
<ul class="article-meta-details">
<li>
<time datetime="2019-03-18" itemprop="datePublished">
18 Mar 2019
</time>
</li>
</ul>
</div>
</article>
<article>
<div class="listing-article-list-block">
<ul class="article-meta-above-title">
<li>
<a class="inquirer-link" href="/category/communications/">Communications</a>
</li>
</ul>
<div class="listings-article-title"><a title="Mega-outage takes Facebook, Instagram and WhatsApp down for 14 hours" href="/inquirer/news/3072555/facebook-whatsapp-instagram-outage">Mega-outage takes Facebook, Instagram and WhatsApp down for 14 hours</a></div>
<ul class="article-meta-details">
<li>
<time datetime="2019-03-14" itemprop="datePublished">
14 Mar 2019
</time>
</li>
</ul>
</div>
</article>
</div>
</div>
</section>

<div id="rdm-below-article-body"></div>
<ul class="tools-container">
<li>
<div title="Tweet" class="article-tools twitter-icon icons pos1">
<span title="Tweet" class="screen-reader-text">Tweet</span>
<a href="https://twitter.com/share?text=WhatsApp+hack+allowed+surveillance+of+key+users+of+Facebook%27s+%27secure%27+chat+app&amp;url=https://www.theinquirer.net/3075717/&via=inq" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Facebook" class="article-tools facebook-icon icons pos2">
<span class="screen-reader-text">Facebook</span>
<a href="https://www.facebook.com/sharer.php?u=https://www.theinquirer.net/3075717" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div data-social-tracking="added" title="Reddit" class="article-tools reddit-icon icons pos4">
<a href="https://reddit.com/submit?url=WhatsApp+hack+allowed+surveillance+of+key+users+of+Facebook%27s+%27secure%27+chat+app&amp;url=https://www.theinquirer.net/3075717" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div data-social-tracking="added" title="Stumbleupon" class="article-tools stumbleupon-icon icons pos5">
<a href="http://www.stumbleupon.com/submit?url=https://www.theinquirer.net/3075717" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>

<li>
<div title="Send to" class="article-tools email-icon icons pos6">
<span class="screen-reader-text">Send to</span>
<a target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#eed19d9b8c848b8d9ad3b9868f9a9daf9e9ece868f8d85ce8f828281998b8ace9d9b9c988b8782828f808d8bce8188ce858b97ce9b9d8b9c9dce8188cea88f8d8b8c818185c88f839ed5cdddd7d59dcec88f839ed5cdddd7d59d8b8d9b9c8bc88f839ed5cdddd7d5ce8d868f9ace8f9e9ec88f839ed58c818a97d3cbdeaacbdeafcbdeaacbdeaf869a9a9ecbddafcbdca8cbdca8999999c09a868b87809f9b879c8b9cc0808b9acbdca8ddded9dbd9dfd9">&nbsp;</a>
</div>
</li>
</ul>

<ul class="meta-taxonomy-list related-links">
<li>
Topics
</li>
<li>
<a href="/category/communications/security/">Security</a>
</li>
<li>
<a href="/tag/security/">Security</a>
</li>
<li>
<a href="/tag/privacy/">Privacy </a>
</li>
<li>
<a href="/tag/hacking/">Hacking</a>
</li>
<li>
<a href="/tag/facebook/">Facebook</a>
</li>
<li>
<a href="/tag/whatsapp/">whatsapp</a>
</li>
</ul>


</div>
</div>
</article>

<div id="rdm-above-comments"></div>
<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>

/**
*  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
*  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/
var disqus_config = function () {
this.page.url = 'http://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack';  // Replace PAGE_URL with your page's canonical URL variable
this.page.identifier = '/inquirer/news/3075717/whatsapp-spyware-hack'; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
};

(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');
s.src = '//theinq.disqus.com/embed.js'; // Replace SITE_SHORTNAME with your site’s shortname
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<div id="rdm-above-series-blog"></div>
<div id="rdm-above-related"></div>

<div id="rdm-above-more-news"></div>
<section class="news-articles">
<header class="related-listings-header">
<h4 itemprop="name">INQ Latest</h4>
</header>
<div class="section group">
<article class="col span_2_of_4 first-element">
<div class="image-text-group-a">
<a href="/inquirer/news/3075902/apple-zombieland-fix-mac-performance-hit"><img title="Apple&#39;s ZombieLoad fix hits Mac performance by up to 40 per cent" alt="Apple&#39;s ZombieLoad fix hits Mac performance by up to 40 per cent" src="/w-images/7233848f-da86-4601-be31-8c228f420fa2/2/Zombielaptop-230x142.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Apple&#39;s ZombieLoad fix hits Mac performance by up to 40 per cent" href="/inquirer/news/3075902/apple-zombieland-fix-mac-performance-hit">Apple&#39;s ZombieLoad fix hits Mac performance by up to 40 per cent</a></h5>
<p class="section-story">
It &#39;Just Works&#39;... more slowly
</p>
<ul class="article-meta-details">
<li>
<a class="inquirer-link" href="/category/hardware/security/">Security</a>
</li>
<li>
<time datetime="2019-05-16" itemprop="datePublished">
16 May 2019
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3075900/sandisk-1tb-microsd-on-sale"><img title="Sandisk wins the race to put the first 1TB microSD card in stores" alt="Sandisk wins the race to put the first 1TB microSD card in stores" src="/w-images/47dc8354-74a4-497d-a135-583228219e89/2/WD1TB-230x142.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Sandisk wins the race to put the first 1TB microSD card in stores" href="/inquirer/news/3075900/sandisk-1tb-microsd-on-sale">Sandisk wins the race to put the first 1TB microSD card in stores</a></h5>
<p class="section-story">
Others promised, Sandisk has delivered.
</p>
<ul class="article-meta-details">
<li>
<a class="inquirer-link" href="/category/hardware/storage/">Storage</a>
</li>
<li>
<time datetime="2019-05-16" itemprop="datePublished">
16 May 2019
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3075899/samsung-galaxy-fold-fix-release-date"><img title="Galaxy Fold might debut next month as Samsung &#39;fixes screen defect&#39;" alt="Galaxy Fold might debut next month as Samsung &#39;fixes screen defect&#39;" src="/w-images/d96cb79b-4acf-4036-b2f8-69ebd3faadba/3/SamsungGalaxyFoldFeb2019590360-230x142.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Galaxy Fold might debut next month as Samsung &#39;fixes screen defect&#39;" href="/inquirer/news/3075899/samsung-galaxy-fold-fix-release-date">Galaxy Fold might debut next month as Samsung &#39;fixes screen defect&#39;</a></h5>
<p class="section-story">
But it could still be forced to cancel pre-orders
</p>
<ul class="article-meta-details">
<li>
<a class="inquirer-link" href="/category/hardware/phones/">Phones</a>
</li>
<li>
<time datetime="2019-05-16" itemprop="datePublished">
16 May 2019
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3075898/google-titan-key-hack"><img title="Google&#39;s 2FA keys can be hacked due to Bluetooth config borkage" alt="Google&#39;s 2FA keys can be hacked due to Bluetooth config borkage" src="/w-images/c3d50387-11f2-455a-82a3-442e6741025e/3/GoogleTitanSecurityKey-230x142.png" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Google&#39;s 2FA keys can be hacked due to Bluetooth config borkage" href="/inquirer/news/3075898/google-titan-key-hack">Google&#39;s 2FA keys can be hacked due to Bluetooth config borkage</a></h5>
<p class="section-story">
But only by attackers in the vicinity and with a shedload of patience
</p>
<ul class="article-meta-details">
<li>
<a class="inquirer-link" href="/category/hardware/security/">Security</a>
</li>
<li>
<time datetime="2019-05-16" itemprop="datePublished">
16 May 2019
</time>
</li>
</ul>
</div>
</article>
</div>
</section>


<section class="taboola-content" id="taboola-below-article-thumbnails">
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
		        window._taboola = window._taboola || [];
		        _taboola.push({
		        mode: 'thumbnails-rd-a',
		        container: 'taboola-below-article-thumbnails',
		        placement: 'Below Article Thumbnails',
		        target_type: 'mix'
		        });
		    </script>
</section>
<div id="rdm-above-comments"></div>
<div id="disqus_thread"></div>
<script>

/**
*  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
*  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/
var disqus_config = function () {
this.page.url = 'http://www.theinquirer.net/inquirer/news/3075717/whatsapp-spyware-hack';  // Replace PAGE_URL with your page's canonical URL variable
this.page.identifier = '/inquirer/news/3075717/whatsapp-spyware-hack'; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
};

(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');
s.src = '//theinq.disqus.com/embed.js'; // Replace SITE_SHORTNAME with your site’s shortname
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<div class="scrollup">
Back to Top
</div>
</div>
<div role="complementary" class="sidebar">
<div id="rdm-rhc-top" class="ad-slot"></div>

<section class="popular-articles">
<header class="related-listings-header">
<h4 itemprop="name">Most read</h4>
</header>
<div class="section group">
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3069266/oneplus-7-pro-price-specs-oneplus-7-pro-7-pro-5g-7-official"><img title="OnePlus 7 Pro price, deals and specs: OnePlus unveils 7 Pro, 7 Pro 5G and OnePlus 7" alt="OnePlus 7 Pro price, deals and specs: OnePlus unveils 7 Pro, 7 Pro 5G and OnePlus 7" src="/w-images/c5f77222-a0be-4687-928f-93edf0d0016e/3/fill/OnePlus7Pro1-140x87.png" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="OnePlus 7 Pro price, deals and specs: OnePlus unveils 7 Pro, 7 Pro 5G and OnePlus 7" href="/inquirer/news/3069266/oneplus-7-pro-price-specs-oneplus-7-pro-7-pro-5g-7-official">OnePlus 7 Pro price, deals and specs: OnePlus unveils 7 Pro, 7 Pro 5G and OnePlus 7</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3066173/iphone-11-release-date-specs-price-leak-shows-off-camera-bulge-colour-options"><img title="iPhone 11 release date, specs and price: Leak shows off camera bulge and new colour options" alt="iPhone 11 release date, specs and price: Leak shows off camera bulge and new colour options" src="/w-images/115581bc-64dc-4dc9-ab3e-03d7c4c20e01/2/iPhoneXI5K3cashkaro-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="iPhone 11 release date, specs and price: Leak shows off camera bulge and new colour options" href="/inquirer/news/3066173/iphone-11-release-date-specs-price-leak-shows-off-camera-bulge-colour-options">iPhone 11 release date, specs and price: Leak shows off camera bulge and new colour options</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3075833/huawei-offers-no-spy-contracts-and-promises-to-shut-down-if-forced-to-spy-for-china"><img title="Huawei offers &#39;no-spy&#39; contracts and promises to &#39;shutdown&#39; if China forces backdoors" alt="Huawei offers &#39;no-spy&#39; contracts and promises to &#39;shutdown&#39; if China forces backdoors" src="/w-images/4305c529-c248-4095-9ad5-7be10e4d1549/1/huaweihilink-140x87.png" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Huawei offers &#39;no-spy&#39; contracts and promises to shut down if China forces backdoors" href="/inquirer/news/3075833/huawei-offers-no-spy-contracts-and-promises-to-shut-down-if-forced-to-spy-for-china">Huawei offers &#39;no-spy&#39; contracts and promises to shut down if China forces backdoors</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3075838/google-finds-ways-to-cover-your-mobile-in-even-more-advertising"><img title="Google finds ways to cover your mobile in even more advertising" alt="Google finds ways to cover your mobile in even more advertising" src="/w-images/dafa83da-091a-42be-a3f7-05babb3bb5ab/1/googletabletwebpage-140x87.jpeg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Google finds ways to cover your mobile in even more advertising" href="/inquirer/news/3075838/google-finds-ways-to-cover-your-mobile-in-even-more-advertising">Google finds ways to cover your mobile in even more advertising</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3075837/microsoft-windows-xp-patch-wormable-flaw"><img title="Microsoft flings surprise patch at Windows XP to fix WannaCry-like &#39;wormable&#39; flaw" alt="Microsoft flings surprise patch at Windows XP to fix WannaCry-like &#39;wormable&#39; flaw" src="/w-images/4e8b56d2-4c80-4e41-917c-fb9d5d7d8f64/0/softwarebug-140x87.jpeg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Microsoft flings surprise patch at Windows XP to fix WannaCry-like &#39;wormable&#39; flaw" href="/inquirer/news/3075837/microsoft-windows-xp-patch-wormable-flaw">Microsoft flings surprise patch at Windows XP to fix WannaCry-like &#39;wormable&#39; flaw</a>
</h5>
</div>
</article>
</div>
</section>

<div id="rdm-rhc-bottom" class="ad-slot"></div>
</div>
</main>
</div>
</div>
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-above-footer" class="ad-slot-full"></div>
</div>
</div>
</aside>
<footer class="main-footer">
<div class="main-footer-content main-footer-links">
<div class="main-footer-content-inner content-width">
<ul class="main-footer-nav">
<li class="menu-title"><a title="Contact" href="https://www.theinquirer.net/static/aboutus">Contact</a></li>
<li class="menu-title"><a title="Marketing solutions" href="http://btgmarketingsolutions.incisivemedia.com/">Marketing solutions</a></li>
<li class="menu-title"><a title="Enterprise IT Events" href="http://www.enterpriseitevents.com/">Enterprise IT Events</a></li>
<li class="menu-title"><a title="About Incisive Media" href="http://www.incisivemedia.com/our-story/" target="_blank" rel="noopener noreferrer">Incisive Media</a></li>
<li class="menu-title"><a title="Terms and conditions" href="http://www.incisivemedia.com/terms-and-conditions/" target="_blank" rel="noopener noreferrer">Terms &amp; conditions</a></li>
<li class="menu-title"><a title="Policies" href="https://www.incisivemedia.com/terms-conditions/#policies" target="_blank" rel="noopener noreferrer">Policies</a></li>
<li class="menu-title"><a title="Careers" href="https://www.incisivemedia.com/our-careers/?utm_source=the_inquirer&amp;utm_medium=footer_navigation&amp;utm_campaign=corporate_careers_links" target="_blank" rel="noopener noreferrer">Careers</a></li>
</ul>
<ul class="footer-tools-content main-footer-align-right">
<li>
<div class="nav-tools rss-icon">
<a href="//www.theinquirer.net/static/rss" target="_blank">RSS</a>
</div>
</li>
<li>
<div class="nav-tools twitter-icon">
<a href="//twitter.com/INQ" target="_blank">Twitter</a>
</div>
</li>
<li>
<div class="nav-tools linkedin">
<a href="//www.linkedin.com/showcase/the-inquirer" target="_blank">LinkedIn</a>
</div>
</li>
<li>
<div class="nav-tools newsletters">
<a href="http://email.theinquirer.net/k/Incisive-Business/inq_nlsuf" target="_blank">Newsletters</a>
</div>
</li>
<li>
<div class="nav-tools facebook-icon">
<a href="//www.facebook.com/pages/The-Inquirer/30395818327" target="_blank">Facebook</a>
</div>
</li>
<li>
<div class="nav-tools youtube">
<a href="//www.youtube.com/theinquirer" target="_blank">YouTube</a>
</div>
</li>
</ul>
</div>
</div>
<div class="main-footer-content main-footer-copyright">
<div class="main-footer-content-inner content-width">
<div class="incisivemedia-footer">
<p class="corp-logo" style="float: left; padding: 20px 10px 0px 5px;"><a title="Incisive Media" href="https://www.incisivemedia.com/" target="_blank" rel="noopener noreferrer"><img src="//assets.incisivemedia.com/production/global/images/im_logo_white.png" width="150" height="38" /></a></p>
<p class="copyright-full">&copy; Incisive Business Media (IP) Limited, Published by Incisive Business Media Limited, New London House, 172 Drury Lane, London WC2B 5QR, registered in England and Wales with company registration numbers 09177174 &amp; 09178013</p>
</div>
<div class="incisivemedia-accreditation">
<div class="accredit-text"><a href="http://www.incisivemedia.com/accreditations" target="_blank" rel="noopener noreferrer">Digital publisher of the year</a></div>
<div class="accreditation-logos"><span class="screen-reader-text">Digital publisher of the year 2010, 2013, 2016 &amp; 2017</span></div>

<script defer="defer" src="//get.s-onetag.com/c80c8815-1563-4bcb-9219-e5a9f57282c0/tag.min.js" async=""></script>
<script src="https://s.skimresources.com/js/3305X620930.skimlinks.js" type="text/javascript"></script>
</div>
</div>
</div>
</footer>
</div>
<script src="/javascripts/cookie.js"></script>
<script type="text/javascript">
	jQuery(document).ready(function() {
		if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
			var userlogin_path=location.pathname;
			if(userlogin_path == "/userlogin"){
				$("span#login_error_message_header").html(getCookie("series_token_error_message").replace(/\+/g, " ")).show();
				deleteCookie("series_token_error_message");
			}}});
	jQuery(document).ready(function() {
		$("#userlogin .btn.login").on("click",function(){
			$("span#login_error_message_header").html("").hide();
		})});
</script>
<script type="text/javascript">
	jQuery(document).ready(function() {
		if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
			if(getCookie("series_token_error_message").match("articles$") !=null){
				$("span#login_error_message_teaser").html(getCookie("series_token_error_message").replace(/\+/g, " ").replace(/\w+$/,'')).show();
				deleteCookie("series_token_error_message");
			}
		}
	});
	jQuery(document).ready(function() {
		$("#login_barrier .login_submit").on("click",function(){
			$("span#login_error_message_teaser").html("").hide();
		});});
</script>
<script src="//assets.theinquirer.net/cdn/inq/scripts/scripts.js"></script>
<script src="/javascripts/KRESearch.js"></script>
<script type="text/javascript">
	jQuery(document).ready(function() {
		$("#login").hover(function(){
			$(".login-offset").hide();
		});
		setTimeout(function(){
			jQuery("#register,#login,#follow,#free-trial").show();
			if(getCookie("logged_in") == "false"){
				jQuery("#register,#login,#follow,#free-trial").show();
				jQuery("#user").hide();
			}else if(getCookie("logged_in") == "true"  || getCookie("logged_in") == "expired"|| getCookie("logged_in") == null){
				if(getCookie("first_name")!= null && getCookie("first_name")!="" && getCookie("subc")!=""){
					$("#user,#follow").show();
					$("#register,#login,#free-trial").hide();
					jQuery(".user-info").html('My account');
					if(getCookie("institutional_login") == "true"){
						if(getCookie("individual_login") == "true"){
							$(".individual").show();
							$('.institutional').hide();
							$(".user-info").html('My account');
							$("#user").removeClass("main-top-institution");
						}else{
							$(".individual").hide();
							$(".user-info").html('Welcome');
							$("#user").addClass("main-top-institution");
						}
					}else{
						$(".individual").show();
						$("#user").removeClass("main-top-institution");
					}
				}else{
					jQuery.ajax({
						type : 'GET',
						dataType : 'html',
						beforeSend : function(xhr) {
							xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'))
						},
						url : '/user_info',
						success : function(data) {
							if(getCookie("logged_in") == "true" || getCookie("logged_in") == "expired" ){
								if(getCookie("first_name")!= null && getCookie("subc")!= null && getCookie("first_name")!="" && getCookie("subc")!=""){
									$("#user,#follow").show();
									$("#register,#login,#free-trial").hide();
									jQuery(".user-info").html('My account');
									if(getCookie("institutional_login") == "true"){
										if(getCookie("individual_login") == "true"){
											$(".individual").show();
											$('.institutional').hide();
											$(".user-info").html('My account');
											$("#user").removeClass("main-top-institution");
										}else{
											$(".individual").hide();
											$('.institutional').show();
											$(".user-info").html('Welcome');
											$("#user").addClass("main-top-institution");
										}
									}else{
										$(".individual").show();
										$("#user").removeClass("main-top-institution");
									}
								}
							}
							else{
								$("#register,#login,#follow,#free-trial").show();
								if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
									var userlogin_path=location.pathname;
									if(userlogin_path != "/userlogin" &&  (getCookie("series_token_error_message").match("articles$") == null)){
										location.pathname="/userlogin";
									}}
							}
						}
					});
				}
			}
		}, 1000);
		$("#user").hover(function(event){
			event.preventDefault();
			if(getCookie("institutional_login") == "true"){
				if(getCookie("individual_login") == "true"){
					$(".individual").show();
					$('.institutional').hide();
				}else{
					$(".individual").hide();
					$('.institutional').show();
				}
			}
		});
	});
</script>
<script type="text/javascript">
	/* article teaser csrf token */
	$(function(){
		jQuery.ajax({
			url : '/article_teaser_login',
			beforeSend : function(xhr) {
				xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
				$( "#export_loaders" ).show();
			},
			success : function(data) {
				$( "#export_loaders" ).hide();
				$(".art_teaser").html(data);
			}
		});
	});
</script>
<script type="text/javascript">
	/*script for login */

	jQuery(document).on('click', '.login_form_submit.login_submit', function(event) {
		event.preventDefault();
		jQuery.ajax({
			url : '/wps/authentication/verify_subscription_login',
			type : 'POST',
			data : jQuery("#userloginpop").serialize(),
			dataType : 'json',
			beforeSend : function(xhr) {
				xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
				$("#follow,#register,#login,#free-trial").hide();
				$( "#export_loaders" ).show();
			},
			success : function(data) {
				if (data.status == "true") {
					$( "#export_loaders" ).hide();
					$("#follow,#user").show();
					location.reload();
				} else {
					jQuery("#register,#login,#follow,#free-trial").show();
					$( "#export_loaders" ).hide();
					jQuery('#login_error_message_header,#login_error_message_teaser').show();
					jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
				}
			}
		});

	});
	jQuery(document).on('click', '.btn.login', function(event) {
		event.preventDefault();
		jQuery.ajax({
			url : '/wps/authentication/verify_subscription_login',
			type : 'POST',
			data : jQuery("#userlogin").serialize(),
			dataType : 'json',
			beforeSend : function(xhr) {
				xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
				$( "#export_loaders" ).show();
			},
			success : function(data) {
				if (data.status == "true") {
					$( "#export_loaders" ).hide();
					var a=$(".cls_redirect").attr("value");
					location.href=a;
				} else {
					jQuery("#register,#login,#follow,#free-trial").show();
					$( "#export_loaders" ).hide();
					jQuery('#login_error_message_header,#login_error_message_teaser').show();
					jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
				}
			}
		});

	});
	jQuery(document).on('click', '.submit_style.login_submit', function(event) {
		event.preventDefault();

		jQuery.ajax({
			url : '/wps/authentication/verify_subscription_login',
			type : 'POST',
			data : jQuery('#login_barrier').serialize(),
			dataType : 'json',
			beforeSend : function(xhr) {
				xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
				setTimeout(function(){
					$( "#export_loaders" ).show();
				}, 1000);
			},
			success : function(data) {
				if (data.status == "true") {
					$( "#export_loaders" ).hide();
					location.reload()
				} else {
					jQuery("#register,#login,#follow,#free-trial").show();
					$( "#export_loaders" ).hide();
					jQuery('#login_error_message_header,#login_error_message_teaser').show();
					jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
				}
			}
		});
	});
</script>
<script type="text/javascript">
		/* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
		var disqus_shortname = 'theinq'; // required: replace example with your forum shortname
		var disqus_identifier = "/inquirer/news/3075717/whatsapp-spyware-hack";
		/* * * DON'T EDIT BELOW THIS LINE * * */
		(function () {
			var s = document.createElement('script');
			s.async = true;
			s.type = 'text/javascript';
			s.src = '//theinq.disqus.com/count.js';
			(document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
		}());
	</script>

<script type="text/javascript">
	$(document).on('click', '.refine-search-toggle', function(e){
		e.stopPropagation();
		$(".refine-search-options").slideToggle();
		$(this).toggleClass("selected");
	});
</script>
<script>
	$(document).on('click','.search_date,.search_sort',function(e){
		e.stopPropagation();
		var type = $(this).attr('data-id');
		if($(this).attr('data-con')=='sort'){
			$("#filters #sort").attr('value',type);
			$(".search_sort").parent().removeClass('sortby-selected');
			$(this).parent().addClass('sortby-selected');
		}else{
			$('.selected_date option[value='+ type +']').attr('selected','selected');
			$(".selected_date").val(type);
			$(".search_date").parent().removeClass('sortby-selected');
			$(this).parent().addClass('sortby-selected');
		}
		$("#filters").submit();
	});

</script>
<script type="text/javascript" src='//assets.theinquirer.net/javascript/live/the_inquirer/javascript-the_inquirer.body.min.js'></script>

<script type="text/javascript">
		window._taboola = window._taboola || [];
		_taboola.push({flush: true});
	</script>
<script id="dsq-count-scr" src="//theinq.disqus.com/count.js" async></script> 
</body>
</html>
