<!DOCTYPE html>
<html class="no-js" itemscope itemtype="http://schema.org/WebPage" lang="en" prefix="og: http://ogp.me/ns#">
<head>
<meta http-equiv="Content-Type" content="text/html;charset=utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"30b3ffac80","applicationID":"29725091","transactionName":"dAwPFRELDlhUFBpDQkRMEQAEAREbQg5aQ21WERUIAAgH","queueTime":0,"applicationTime":1658,"agent":""}</script>
<script type="text/javascript">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</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="format-detection" content="telephone=no" />
<meta name="HandheldFriendly" content="True" />
<meta http-equiv="Content-Style-Type" content="text/css" />
<meta http-equiv="Content-Script-Type" content="text/javascript" />
<meta name="google-site-verification" content="Q6-HYgph0PP5v8F5bD1wZ1Z8Pcg2QQd47eiwnlJ07NU" />
<title>Huawei refutes UK gov&#39;s spying concerns in open letter to parliament</title>
<meta name="description" content="Huawei refutes UK gov&#39;s spying concerns in open letter to parliament" />
<meta name="keywords" content="huawei, UK government, Security, china" />

<meta name="DCSext.topics" content="huawei;uk-government;security;china" />

<link rel="canonical" href="https://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament" />
<link rel="syndication-source" href="https://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament" />
<link rel="original-source" href="https://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament" />
<meta property="article:modified_time" content="2019-02-07T09:30:53+00:00" />
<meta property="article:published_time" content="2019-02-07T09:30:53+00:00" />
<meta name="news_keywords" content="Friction ,huawei,UK government,Security,china" />
<meta http-equiv="Set-Cookie" content="last_page_viewed=https://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament;path=/;expires=2019-02-07 11:31:23 +0000;domain=.theinquirer.net;" />
<meta http-equiv="Set-Cookie" content="last_visited_page=/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament;path=/;expires=2019-02-07 11:31:24 +0000;domain=.theinquirer.net;">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon.png" rel="apple-touch-icon" sizes="57x57">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon-76x76.png" rel="apple-touch-icon" sizes="76x76">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon-120x120.png" rel="apple-touch-icon" sizes="120x120">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon-152x152.png" rel="apple-touch-icon" sizes="152x152">
<link href="https://www.theinquirer.net/images/favicons/apple-touch-icon-180x180.png" rel="apple-touch-icon" sizes="180x180">
<link href="https://www.theinquirer.net/images/favicons/icon-hires.png?0456789" rel="icon" sizes="192x192">
<link href="https://www.theinquirer.net/images/favicons/icon-normal.png?0456785" rel="icon" sizes="128x128">
<link href="https://www.theinquirer.net/images/favicons/32x32.ico" rel="shortcut icon" type="image/png">
<meta name="msapplication-TileImage" content="https://www.theinquirer.net/images/favicons/mstile-144x144.png?100518">
<meta name="msapplication-TileColor" content="#fd1d01">
<meta property="og:title" content="Huawei refutes UK gov&#39;s spying concerns in open letter to parliament | TheINQUIRER " />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament" />
<meta property="og:image" content="http://www.theinquirer.net/w-images/2852a379-c310-4d93-9eff-52f896b8dc93/1/Huawei-370x229.jpg" />
<meta property="og:site_name" content="http://www.theinquirer.net" />
<meta property="og:description" content="But firm admits there&#39;s room for improvement,Friction ,huawei,UK government,Security,china" " />
<meta name="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="INQ" />
<meta name="twitter:domain" content="//www.theinquirer.net/">
<meta property="twitter:creator" content="CarlyPage_" />
<meta property="twitter:url" content="https://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament" />
<meta property="twitter:image" content="http://www.theinquirer.net/w-images/2852a379-c310-4d93-9eff-52f896b8dc93/1/Huawei-370x229.jpg" />
<meta property="twitter:description" content="But firm admits there&#39;s room for improvement" />
<link href="https://plus.google.com/theinquirer" rel="publisher" />
<meta itemprop="name" content="Huawei refutes UK gov&#39;s spying concerns in open letter to parliament | TheINQUIRER" />
<meta itemprop="description" content="But firm admits there&#39;s room for improvement,Friction ,huawei,UK government,Security,china" />
<meta itemprop="image" content="http://www.theinquirer.net/w-images/2852a379-c310-4d93-9eff-52f896b8dc93/1/Huawei-370x229.jpg" />
<link href="//assets.theinquirer.net/cdn/inq/styles/styles.css" media="all" rel="stylesheet" type="text/css">
<!--[if lt IE 9]>
		<script src="http://assets.theinquirer.net/cdn/global/scripts/html5shiv.js"></script>
		<link href="http://assets.theinquirer.net/respond-proxy.html" id="respond-proxy" rel="respond-proxy" />
		<link href="/images/respond.proxy.gif" id="respond-redirect" rel="respond-redirect" />
		<![endif]-->
<!--[if lt IE 9]>
        	<script src="http://assets.theinquirer.net/cdn/global/scripts/respond.js"></script>
           	<script src="/javascripts/respond.proxy.js"></script>
		<![endif]-->
<script src="//assets.theinquirer.net/cdn/global/scripts/jquery_1-11-2.min.js"></script>


<script type="text/javascript" language="Javascript">
universal_variable_string = '{ "content": { "article":"news", "source":"inquirer", "author":"carly-page", "medium":"text", "published":"2019-02-07T09:30:53+00:00", "tag":["huawei","uk-government","security","china"], "image":"/w-images/2852a379-c310-4d93-9eff-52f896b8dc93/1/Huawei-185x114.jpg", "restriction":"default","barrier":"free"}, "page": { "url": "https://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament", "title": "Huawei refutes UK gov&amp;#39;s spying concerns in open letter to parliament", "description": "But firm admits there&amp;#39;s room for improvement", "type": "article", "category": "friction", "parentcategory": "friction", "id": "3070617", "environment": "live", "site":"theinquirer.net", "platform":"desktop"} }';
</script>

<script type="text/javascript" src='//assets.theinquirer.net/javascript/live/the_inquirer/javascript-the_inquirer.head.min.js'></script>

<script>
		(function(H){H.className=H.className.replace(/\bno-js\b/,'')})(document.documentElement);
		
		  !function(){"use strict";function e(e,t,s){e.addEventListener?e.addEventListener(t,s,!1):e.attachEvent&&e.attachEvent("on"+t,s)}function t(e){return window.localStorage&&localStorage.font_css_cache&&localStorage.font_css_cache_file===e}function s(){if(window.localStorage&&window.XMLHttpRequest)if(t(n))c(localStorage.font_css_cache);else{var e=new XMLHttpRequest;e.open("GET",n,!0),e.onreadystatechange=function(){4===e.readyState&&200===e.status&&(c(e.responseText),localStorage.font_css_cache=e.responseText,localStorage.font_css_cache_file=n)},e.send()}else{var s=document.createElement("link");s.href=n,s.rel="stylesheet",s.type="text/css",document.getElementsByTagName("head")[0].appendChild(s),document.cookie="font_css_cache"}}function c(e){var t=document.createElement("style");t.setAttribute("type","text/css"),document.getElementsByTagName("head")[0].appendChild(t),t.styleSheet?t.styleSheet.cssText=e:t.innerHTML=e}var n="//assets.theinquirer.net/cdn/inq/styles/fonts/sourcesanspro.css?ver=1";window.localStorage&&localStorage.font_css_cache||document.cookie.indexOf("font_css_cache")>-1?s():e(window,"load",s)}();
		</script>
<script type="text/javascript">
	  window._taboola = window._taboola || [];
	  _taboola.push({article:'auto'});
	  !function (e, f, u) {
	    e.async = 1;
	    e.src = u;
	    f.parentNode.insertBefore(e, f);
	  }(document.createElement('script'),
	  document.getElementsByTagName('script')[0],
	  '//cdn.taboola.com/libtrc/incisivemedia-theinquirer/loader.js');
	 </script>
<script>
        var _prum = [['id', '58fdbe6c837975e23a7862b3'],
        ['mark', 'firstbyte', (new Date()).getTime()]];
        (function() {
        var s = document.getElementsByTagName('script')[0]
        , p = document.createElement('script');
        p.async = 'async';
        p.src = '//rum-static.pingdom.net/prum.min.js';
        s.parentNode.insertBefore(p, s);
        })();
    </script>
</head>
<body class="article inquirer  ">
<div id="rdm-overlay" class="ad-slot-overlay"></div>
<div id="rdm-wallpaper" class="ad-slot-wallpaper"></div>
<div class="container">
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-above-header" class="ad-slot-full"></div>
</div>
</div>
</aside>
<div class="menu-sidebar">
<div class="menu-sidebar-inner">
<div class="search-3 header-search-holder blur">
<form id="search_form" action="/search" accept-charset="UTF-8" method="get">
<input type="submit" value="" aria-labelledby="Search" />
<span>
<input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
</span>
<input type="hidden" name="per_page" id="per_page" value="48" class="hidden_style" />
<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form> </div>
</div>
<nav class="mobile-nav">
<ul class="mobile-nav-ul">
<li class="active">
<div class="mobile-menu-title">
<a title="Home" href="/">Home</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="News" href="/type/news">News</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Artificial Intelligence" href="/tag/ai">Artificial Intelligence</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Internet of Things" href="/tag/iot">Internet of Things</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Open Source" href="/tag/open-source">Open Source</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Hardware" href="/category/hardware">Hardware</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Software" href="/category/software">Software</a>
</div>
</li>
<li>
<div class="mobile-menu-title">
<a title="Security" href="/tag/security">Security</a>
</div>
</li>
</ul>
</nav>
<div class="menu-sidebar-inner">
<ul class="sidebar-list">
<li>
<a href="//www.computing.co.uk/static/resources" target="_blank">Whitepapers</a>
</li>
<li>
<a href="/inquirer/content-hub/3030163/data-strategy-spotlight">Data Strategy Spotlight</a>
</li>
<li class="nav-tools newsletters">
<a href="http://email.theinquirer.net/k/Incisive-Business/inq_nlsuf" target="_blank">Newsletters</a>
</li>
</ul>
</div>
</div>
<nav class="main-top-nav">
<ul class="main-top-content main-top-menu content-width">
<li class="main-top-title main-top-tab-panel main-top-hound" id="hound">
<a href="//www.computing.co.uk/static/resources" target="_blank">Whitepapers</a>
<ul class="menu-top-panel">
<li>

<div class="section group content">
<div class="col span-lrg_4_of_5">
<section class="top-panel-paper">
<div class="image-text-group-a">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3546&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$"><img src="/w-images/250ff076-17cc-47ca-8825-3cbe7db5869c/1/inqlogo-120x194.jpeg" alt="Inqlogo 120x194" /></a>
</div>
<div class="image-text-group-b">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3546&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Five things you should look for in choosing a Testing provider</a>
<p>Choosing a Testing Partner can be complex.&nbsp; So what do you look for?&nbsp; This guide offers insight into the qualities you must look for in choosing a Testing provider.&nbsp; Download now to learn more.</p>
<a target="_blank" class="btn download" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=3546&amp;sid=&amp;lpp_msgid=$AMF_contact_id$-$AMF_contact_guid$">Download</a>
</div>
</section>
<section class="top-panel-paper">
<div class="image-text-group-a">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=1654&amp;sid=$AMF_contact_id$-$AMF_contact_guid$"><img src="/w-images/59308cd1-dd2a-46a1-be10-c0728532bf56/1/inqlogo-120x194.jpeg" alt="Inqlogo 120x194" /></a>
</div>
<div class="image-text-group-b">
<a target="_blank" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=1654&amp;sid=$AMF_contact_id$-$AMF_contact_guid$">Your questions answered: How to protect your data in the cloud</a>
<p>The number of successful cyberattacks per year per company has increased by 46% over the last four years. But what really needs to be considered when exploring a solution? What questions need to be asked? Download to find out...</p>
<a target="_blank" class="btn download" href="https://incisivetrk.cvtr.io/click?pid=300000&amp;lid=1654&amp;sid=$AMF_contact_id$-$AMF_contact_guid$">Download</a>
</div>
</section>
</div>
<div class="col span-lrg_1_of_5">
<section class="hound-search">
<header>
<div class="menu-top-panel-heading">Find whitepapers</div>
<div class="menu-top-panel-subheading">Search by title or subject area</div>
</header>
<aside>
<form target="_blank" name="multi" method="get" id="hound-search" enctype="multipart/form-data" action="//www.computing.co.uk/static/resources-search-results">
<input type="search" id="search-hound" placeholder="Search papers here" tabindex="1" required="" name="wpSearch">
<input type="hidden" value="theinquirer" name="publisher">
<input type="submit" class="btn search-hound">
</form>
</aside>
</section>
<div class="panel-section-footer">
<div class="more-holder">
<a class="more-link" href="//www.computing.co.uk/static/resources" target="_blank">
<svg class="more-icon arrow-right" x="0" y="0" width="0.438em" height="0.938em">
<polygon points="0,3.553 3.947,7.5 0,11.447 0,14.5 7,7.5 0,0.5 "></polygon>
</svg>
View all whitepapers
</a>
</div>
</div>
</div>
</div>

</li>
</ul>
</li>
<li class="main-top-title main-top-align-right main-top-tab-infobox main-top-sociallinks" id="follow" style="display:none;">
<a href="#">Follow us</a>
<ul class="header-tools-content">
<li>
<div class="nav-tools rss-icon">
<a href="//www.theinquirer.net/static/rss" target="_blank">RSS</a>
</div>
</li>
<li>
<div class="nav-tools twitter-icon">
<a href="//twitter.com/INQ" target="_blank">Twitter</a>
</div>
</li>
<li>
<div class="nav-tools linkedin">
<a href="//www.linkedin.com/showcase/the-inquirer" target="_blank">LinkedIn</a>
</div>
</li>
<li>
<div class="nav-tools newsletters">
<a href="http://email.theinquirer.net/k/Incisive-Business/inq_nlsuf" target="_blank">Newsletters</a>
</div>
</li>
<li>
<div class="nav-tools facebook-icon">
<a href="//www.facebook.com/pages/The-Inquirer/30395818327" target="_blank">Facebook</a>
</div>
</li>
<li>
<div class="nav-tools gplus-icon">
<a href="//plus.google.com/+TheinquirerNetUK" target="_blank">Google+</a>
</div>
</li>
<li>
<div class="nav-tools youtube">
<a href="//www.youtube.com/theinquirer" target="_blank">YouTube</a>
</div>
</li>
</ul>
</li>
<li class="main-top-title main-top-align-right main-top-tab-link main-top-register" id="register" style="display:none;">
<a href="http://email.theinquirer.net/k/Incisive-Business/inq_nlsuf" target="_blank">Newsletter</a>
</li>
<li class="main-top-title main-top-align-right main-top-user-status" id="rdm_header_user_status_link"></li>
<li class="main-top-title main-top-tab-link main-top-left02">
<a href="/tag/industry-voice">Industry Voice</a>
</li>
<li class="main-top-title main-top-tab-link main-top-left03">
<a href="/inquirer/content-hub/3030163/data-strategy-spotlight">Data Strategy Spotlight</a>
</li>
</ul>
</nav>
<header role="banner" class="main-head">
<div class="main-head-content content-width">
<div class="site-header">
<div class="site-logo-holder" itemscope itemtype="http://schema.org/Organization">
<div itemprop="name" class="screen-reader-text">
The Inquirer
</div>
<a href="/" title="Return to homepage" class="site-logo"> <img src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw==" alt="The Inquirer" class="sprite inquirer-logo"></a>
</div>
<div class="search-1 header-search-holder blur">
<form id="search_form_bottom" action="/search" accept-charset="UTF-8" method="get">
<input type="submit" value="" aria-labelledby="Search" />
<span>
<input id="search_header" type="search" name="query" value="" required="" placeholder="Search here..." aria-labelledby="Search here">
</span>
<input type="hidden" name="per_page" id="per_page" value="48" class="hidden_style" />
<input type="hidden" name="sort" id="sort" value="relevance1" class="hidden_style" />
<input type="hidden" name="date" id="date" value="this_year" class="hidden_style" />
</form> </div>

</div>
</div>
</header>
<nav class="nav">
<div class="holder">
<div class="hamburger-style" id="nav-toggle" aria-label="Menu">
<span></span>
</div>
<script type="text/conditional-html" id="tablet-conditional-navigation">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</script>
<div id="conditional-navigation" class="">

<nav class="primary-nav nav-colour01" role="navigation" aria-label="Primary">
<ul class="main-menu main-top-content content-width">
<li class="menu-title">
<a title="Home" href="/">Home</a>
</li>
<li class="menu-title">
<a title="News" href="/type/news">News</a>
</li>
<li class="menu-title">
<a title="Artificial Intelligence" href="/tag/ai">Artificial Intelligence</a>
</li>
<li class="menu-title">
<a title="Internet of Things" href="/tag/iot">Internet of Things</a>
</li>
<li class="menu-title">
<a title="Open Source" href="/tag/open-source">Open Source</a>
</li>
<li class="menu-title">
<a title="Hardware" href="/category/hardware">Hardware</a>
</li>
<li class="menu-title">
<a title="Software" href="/category/software">Software</a>
</li>
<li class="menu-title">
<a title="Security" href="/tag/security">Security</a>
</li>
</ul>
</nav>
</div>
<div class="mobile-branding"><a href="/" class="mobile-branding-link" alt="The Inquirer"></a></div>
</div>
</nav>
<aside class="content">
<nav class="trendingbanner">
<ul>
<li>Trending</li>
<li><a title="FaceTime bug" href="https://www.theinquirer.net/inquirer/news/3070110/facetime-bug-was-uncovered-by-a-14-year-old-fortnite-player">FaceTime bug</a></li>
<li><a title="MWC 2019" href="https://www.theinquirer.net/tag/mwc-2019/">MWC 2019</a></li>
<li><a title="AMD Radeon 7" href="https://www.theinquirer.net/inquirer/news/3069513/amd-debunks-claims-its-radeon-7-gpu-will-be-in-short-supply">AMD Radeon VII</a></li>
<li><a title="Galaxy S10" href="https://www.theinquirer.net/inquirer/news/3030399/galaxy-s10-release-date-specs-price-s10-plus-prototype-leak-corner-notch">Galaxy S10</a></li>
<li><a title="Nvidia RTX 2060" href="https://www.theinquirer.net/inquirer/news/3068843/nvidia-rtx-2060-official">Nvidia RTX 2060</a></li>
</ul>
</nav>
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-below-header" class="ad-slot-full"></div>
</div>
</div>
</aside>
<div class="page-content ajax_search">
<header class="article-header">
<div class="content">
<div class="content-inner">
<div class="main-content">
<div class="section group">
<div class="col span_1_of_5">
<img class="print-branding" src="//assets.theinquirer.net/cdn/inq/images/site-logo.png" alt="The Inquirer">
<nav>
<ul class="meta-taxonomy-list breadcrumb">
<li>
<a href="/category/friction/">Friction</a>
</li>
</ul>
</nav>
</div>
<div class="col span_4_of_5">
<h1 itemprop="name" class="article-title">Huawei refutes UK gov&#39;s spying concerns in open letter to parliament</h1>
<h2 class="article-sub-title">But firm admits there's room for improvement</h2>
</div>
</div>
</div>
</div>
</div>
</header>
<div class="content">
<main role="main" class="content-inner">
<div class="main-content">
<article class="section group article">
<div class="col span_1_of_5"></div>
<div class="col span_4_of_5 article-col">
<figure class="main">
<img alt="Huawei refutes UK gov&#39;s spying concerns in open letter to parliament" title="Huawei refutes UK gov&#39;s spying concerns in open letter to parliament" src="/w-images/2852a379-c310-4d93-9eff-52f896b8dc93/1/Huawei-580x358.jpg" />
<figcaption><div class="caption-text"> Huawei refutes UK gov&#39;s spying concerns in open letter to parliament</div></figcaption>
</figure>
<div class="article-meta-container group">
<ul class="meta-taxonomy-list author-dateline ">
<li class="author-dateline-image">
<a title="Carly Page" href="/author/profile/2353/carly-page"><img class="author-pic" alt="Carly Page" src="/w-images/b51bccc8-9f34-4a60-bef3-c624b1d9b97f/0/si27NOLy-100x100.jpg" /></a>
</li>
<li class="author-dateline-name">
<a href="/author/profile/2353/carly-page">Carly Page</a>
</li>
<li class="author-dateline-social">
<div class="meta-twitter">
<a class="twitter-follow" target="_blank" data-component="meta-twitter-handle" data-link-name="twitter-handle" href="https://twitter.com/CarlyPage_">
<svg viewBox="0 0 15 12" height="0.813em" width="0.938em" y="0" x="0" class="twitter-icon">
<path d="M15,1.422c-0.541,0.241-1.128,0.404-1.74,0.477c0.625-0.376,1.106-0.969,1.331-1.678
							c-0.584,0.347-1.235,0.602-1.924,0.737c-0.555-0.59-1.342-0.956-2.21-0.956c-1.675,0-3.03,1.354-3.03,3.028
							c0,0.236,0.027,0.468,0.077,0.692C4.986,3.594,2.756,2.39,1.262,0.556C1.001,1.002,0.851,1.522,0.851,2.078
							c0,1.051,0.536,1.977,1.348,2.521C1.702,4.582,1.237,4.446,0.828,4.222c0,0.013,0,0.025,0,0.037c0,1.467,1.043,2.691,2.429,2.971
							C3.003,7.297,2.735,7.334,2.459,7.334c-0.196,0-0.387-0.018-0.57-0.052c0.384,1.204,1.502,2.078,2.83,2.102
							c-1.035,0.813-2.343,1.299-3.76,1.299c-0.247,0-0.487-0.015-0.726-0.044C1.574,11.498,3.167,12,4.879,12
							c5.571,0,8.616-4.616,8.616-8.618c0-0.13,0-0.263-0.006-0.393C14.08,2.562,14.592,2.031,15,1.422z" />
</svg>
<div class="contact">
@CarlyPage_
</div>
</a>
</div>
</li>
<li class="author-dateline-time">
<time datetime="2019-02-07" itemprop="datePublished">
07 February 2019
</time>
</li>
</ul>
<div class="tools-meta-outer">
<ul class="tools-container">
<li>
<div title="Tweet" class="article-tools twitter-icon icons pos1">
<span title="Tweet" class="screen-reader-text">Tweet</span>
<a href="https://twitter.com/share?text=Huawei+refutes+UK+gov%27s+spying+concerns+in+open+letter+to+parliament&amp;url=https://www.theinquirer.net/3070617/&via=inq" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Facebook" class="article-tools facebook-icon icons pos2">
<span class="screen-reader-text">Facebook</span>
<a href="https://www.facebook.com/sharer.php?u=https://www.theinquirer.net/3070617" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Google plus" class="article-tools gplus-icon icons pos3">
<span class="screen-reader-text">Google plus</span>
<a href="https://plus.google.com/share?url=https://www.theinquirer.net/3070617" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div data-social-tracking="added" title="Reddit" class="article-tools reddit-icon icons pos4">
<a href="https://reddit.com/submit?url=Huawei+refutes+UK+gov%27s+spying+concerns+in+open+letter+to+parliament&amp;url=https://www.theinquirer.net/3070617" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div data-social-tracking="added" title="Stumbleupon" class="article-tools stumbleupon-icon icons pos5">
<a href="http://www.stumbleupon.com/submit?url=https://www.theinquirer.net/3070617" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>

<li>
<div title="Send to" class="article-tools email-icon icons pos6">
<span class="screen-reader-text">Send to</span>
<a target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#714e0204131b1412054c390410061418510314170405140251243a51161e0757101c014a5242484a0251020108181f1651121e1f1214031f0251181f511e01141f511d140505140351051e510110031d18101c141f0557101c014a131e15084c544135544130544135544130190505015442305443375443370606065f051914181f0004180314035f1f140554433742414641474046">&nbsp;</a>
</div>
</li>
</ul>

<div class="article-meta-numbers">
<div class="comment-count">
<a href="https://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament#disqus_thread">0 Comments</a>
</div>
<div class="social-count">
<a href="https://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament"><span class="share-total"></span></a>
</div>
</div>
</div>
</div>
<div class="article-page-body-content">

<p><strong>CHINESE COMMS GIANT</strong> Huawei has refuted allegations of spying in a five-page&nbsp;open letter to the UK parliament.&nbsp;</p>
<p>In <a title="letter" href="https://www.parliament.uk/documents/commons-committees/science-technology/Correspondence/190129-Correspondence-from-Huawei.pdf" target="_blank" rel="noopener noreferrer">the letter</a>, sent to the House of Commons Science and Technology Select Committee on Wednesday, president of Huawei's carrier business Ryan Ding emphasises the investments the company has made in Blighty over the last five years and claims the firm&nbsp;has played a pivotal role in the country's "broadband and wireless infrastructure."</p>
<p>Still, it's this pivotal role that had the UK government concerned in the first place; <a title="UK gov report warns that Huawei kit could pose a 'national security risk'" href="https://www.theinquirer.net/inquirer/news/3036241/uk-gov-report-warns-that-huawei-kit-could-pose-a-national-security-risk" target="_blank" rel="noopener noreferrer">a 2018&nbsp;report warned that&nbsp;"critical" shortfalls&nbsp;in Huawei equipment</a> could pose a potential&nbsp;security risk to the UK's national infrastructure.</p>
<div id="rdm-above-related"></div>
<p>Ding strongly dismissed claims&nbsp;that the company's kit could be used for espionage, noting Huawei's commercial reputation would be destroyed if it was caught spying.</p>
<p>"The governments in some countries have labelled Huawei as a security threat, but they have never substantiated these allegations with solid evidence. For us, the lasting support and trust of our customers worldwide speaks volumes," said Ding.</p>
<p>"Huawei has never and will never use UK-based hardware, software or information gathered in the UK or anywhere else globally, to assist other countries in gathering intelligence. Were Huawei ever to engage in malicious behaviour, it would not go unnoticed - and it would certainly destroy our business."</p>
<p>Still, Ding admits there's some room for improvement in some of its product design processes; while the firm has already moved to integrate security into all its business processes, Huawei&nbsp;pledges to invest $2bn over the next five years to improve the security of its products, but Ding notes it could take three&nbsp;to five years to produce desired results.</p>
<p>"Enhancing our software engineering capabilities is like replacing components on a high-speed train in motion," he said. "It is a complicated and involved&nbsp;process,&nbsp;and will take at least three to five years to see tangible results. We hope the UK government can understand this."</p>
<p>&nbsp;</p>
<p>Ding's letter comes in the same week that the company has been accused, again, of conducting industrial espionage. Following a sting operation at the CES trade show in Las Vegas, Nevada last month, the inventor&nbsp;of a new product called Diamond Glass claims that&nbsp;<a title="Huawei in FBI sting at CES after allegedly reverse engineering another product" href="https://www.theinquirer.net/inquirer/news/3070479/huawei-in-fbi-sting-at-ces-after-allegedly-reverse-engineering-another-product" target="_blank" rel="noopener noreferrer">the company had had the product exported to China and tested with a military laser</a>. &micro;</p>

<section class="further-reading">
<header>
<h4 itemprop="name">Further reading</h4>
</header>
<div class="section group">
<div class="col span_2_of_4">
<article>
<div class="listing-article-list-block">
<ul class="article-meta-above-title">
<li>
<a class="inquirer-link" href="/category/friction/">Friction</a>
</li>
</ul>
<div class="listings-article-title"><a title="Huawei in FBI sting at CES after allegedly reverse engineering another product" href="/inquirer/news/3070479/huawei-in-fbi-sting-at-ces-after-allegedly-reverse-engineering-another-product">Huawei in FBI sting at CES after allegedly reverse engineering another product</a></div>
<ul class="article-meta-details">
<li>
<time datetime="2019-02-05" itemprop="datePublished">
05 Feb 2019
</time>
</li>
</ul>
</div>
</article>
<article>
<div class="listing-article-list-block">
<ul class="article-meta-above-title">
<li>
<a class="inquirer-link" href="/category/hardware/phones/">Phones</a>
</li>
</ul>
<div class="listings-article-title"><a title="Huawei teases its 5G foldable smartphone ahead of MWC debut" href="/inquirer/news/3070298/huawei-teases-its-5g-foldable-smartphone-ahead-of-mwc-debut">Huawei teases its 5G foldable smartphone ahead of MWC debut</a></div>
<ul class="article-meta-details">
<li>
<time datetime="2019-02-01" itemprop="datePublished">
01 Feb 2019
</time>
</li>
</ul>
</div>
</article>
</div>
<div class="col span_2_of_4">
<article>
<div class="listing-article-list-block">
<ul class="article-meta-above-title">
<li>
<a class="inquirer-link" href="/category/hardware/">Hardware</a>
</li>
</ul>
<div class="listings-article-title"><a title="Huawei Mate 20 Pro review" href="/inquirer/review/3064575/huawei-mate-20-pro-review">Huawei Mate 20 Pro review</a></div>
<ul class="article-meta-details">
<li>
<time datetime="2019-01-24" itemprop="datePublished">
24 Jan 2019
</time>
</li>
</ul>
</div>
</article>
<article>
<div class="listing-article-list-block">
<ul class="article-meta-above-title">
<li>
<a class="inquirer-link" href="/category/friction/">Friction</a>
</li>
</ul>
<div class="listings-article-title"><a title="US hits Huawei with 23 charges that go &#39;all the way to the top&#39;" href="/inquirer/news/3070040/us-hits-huawei-with-23-charges-that-go-all-the-way-to-the-top">US hits Huawei with 23 charges that go &#39;all the way to the top&#39;</a></div>
<ul class="article-meta-details">
<li>
<time datetime="2019-01-29" itemprop="datePublished">
29 Jan 2019
</time>
</li>
</ul>
</div>
</article>
</div>
</div>
</section>

<div id="rdm-below-article-body"></div>
<ul class="tools-container">
<li>
<div title="Tweet" class="article-tools twitter-icon icons pos1">
<span title="Tweet" class="screen-reader-text">Tweet</span>
<a href="https://twitter.com/share?text=Huawei+refutes+UK+gov%27s+spying+concerns+in+open+letter+to+parliament&amp;url=https://www.theinquirer.net/3070617/&via=inq" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Facebook" class="article-tools facebook-icon icons pos2">
<span class="screen-reader-text">Facebook</span>
<a href="https://www.facebook.com/sharer.php?u=https://www.theinquirer.net/3070617" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div title="Google plus" class="article-tools gplus-icon icons pos3">
<span class="screen-reader-text">Google plus</span>
<a href="https://plus.google.com/share?url=https://www.theinquirer.net/3070617" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div data-social-tracking="added" title="Reddit" class="article-tools reddit-icon icons pos4">
<a href="https://reddit.com/submit?url=Huawei+refutes+UK+gov%27s+spying+concerns+in+open+letter+to+parliament&amp;url=https://www.theinquirer.net/3070617" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>
<li>
<div data-social-tracking="added" title="Stumbleupon" class="article-tools stumbleupon-icon icons pos5">
<a href="http://www.stumbleupon.com/submit?url=https://www.theinquirer.net/3070617" rel="nofollow" target="_blank">&nbsp;</a>
</div>
</li>

<li>
<div title="Send to" class="article-tools email-icon icons pos6">
<span class="screen-reader-text">Send to</span>
<a target="_blank" rel="nofollow" href="/cdn-cgi/l/email-protection#d8e7abadbab2bdbbace590adb9afbdb1f8aabdbeadacbdabf88d93f8bfb7aefeb9b5a8e3fbebe1e3abf8aba8a1b1b6bff8bbb7b6bbbdaab6abf8b1b6f8b7a8bdb6f8b4bdacacbdaaf8acb7f8a8b9aab4b1b9b5bdb6acfeb9b5a8e3bab7bca1e5fde89cfde899fde89cfde899b0acaca8fdeb99fdea9efdea9eafafaff6acb0bdb1b6a9adb1aabdaaf6b6bdacfdea9eebe8efe8eee9ef">&nbsp;</a>
</div>
</li>
</ul>

<ul class="meta-taxonomy-list related-links">
<li>
Topics
</li>
<li>
<a href="/category/friction/">Friction</a>
</li>
<li>
<a href="/tag/huawei/">huawei</a>
</li>
<li>
<a href="/tag/uk-government/">UK government</a>
</li>
<li>
<a href="/tag/security/">Security</a>
</li>
<li>
<a href="/tag/china/">china</a>
</li>
</ul>


</div>
</div>
</article>

<div id="rdm-above-comments"></div>
<div id="disqus_thread"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>

/**
*  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
*  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/
var disqus_config = function () {
this.page.url = 'http://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament';  // Replace PAGE_URL with your page's canonical URL variable
this.page.identifier = '/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament'; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
};

(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');
s.src = '//theinq.disqus.com/embed.js'; // Replace SITE_SHORTNAME with your site’s shortname
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<div id="rdm-above-series-blog"></div>
<div id="rdm-above-related"></div>

<div id="rdm-above-more-news"></div>
<section class="news-articles">
<header class="related-listings-header">
<h4 itemprop="name">INQ Latest</h4>
</header>
<div class="section group">
<article class="col span_2_of_4 first-element">
<div class="image-text-group-a">
<a href="/inquirer/news/3070628/roaming-charges-return-no-deal-brexit"><img title="Gov tables return of roaming charges in event of no-deal Brexit" alt="Gov tables return of roaming charges in event of no-deal Brexit" src="/w-images/5c7db815-df6f-4cd6-be2b-1f36d7b4c08e/1/roaming-230x142.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Gov tables return of roaming charges in event of no-deal Brexit" href="/inquirer/news/3070628/roaming-charges-return-no-deal-brexit">Gov tables return of roaming charges in event of no-deal Brexit</a></h5>
<p class="section-story">
Free roaming looks set to face the same fate as cheese
</p>
<ul class="article-meta-details">
<li>
<a class="inquirer-link" href="/category/communications/">Communications</a>
</li>
<li>
<time datetime="2019-02-07" itemprop="datePublished">
07 February 2019
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3070621/raspberry-pi-retail-store-opens"><img title="Raspberry Pi opens its first bricks-and-mortar retail store" alt="Raspberry Pi opens its first bricks-and-mortar retail store" src="/w-images/37bdfbf2-b6cc-4b53-b098-799fc6b4dd36/2/RaspberryPiStore-230x142.jpeg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Raspberry Pi opens its first bricks-and-mortar retail store" href="/inquirer/news/3070621/raspberry-pi-retail-store-opens">Raspberry Pi opens its first bricks-and-mortar retail store</a></h5>
<p class="section-story">
Charity blows Raspberries at retail nay-sayers
</p>
<ul class="article-meta-details">
<li>
<a class="inquirer-link" href="/category/hardware/">Hardware</a>
</li>
<li>
<time datetime="2019-02-07" itemprop="datePublished">
07 February 2019
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament"><img title="Huawei refutes UK gov&#39;s spying concerns in open letter to parliament" alt="Huawei refutes UK gov&#39;s spying concerns in open letter to parliament" src="/w-images/2852a379-c310-4d93-9eff-52f896b8dc93/1/Huawei-230x142.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="Huawei refutes UK gov&#39;s spying concerns in open letter to parliament" href="/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament">Huawei refutes UK gov&#39;s spying concerns in open letter to parliament</a></h5>
<p class="section-story">
But firm admits there&#39;s room for improvement
</p>
<ul class="article-meta-details">
<li>
<a class="inquirer-link" href="/category/friction/">Friction</a>
</li>
<li>
<time datetime="2019-02-07" itemprop="datePublished">
07 February 2019
</time>
</li>
</ul>
</div>
</article>
<article class="col span_2_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3070589/amd-allocates-blighty-fewer-than-100-radeon-7-gpus-claims-retailer"><img title="AMD allocates Blighty fewer than 100 Radeon 7 GPUs, claims retailer" alt="AMD allocates Blighty fewer than 100 Radeon 7 GPUs, claims retailer" src="/w-images/9c5cc219-eb85-4c51-abb6-2d3dcda3879f/2/AMDRadeonVIIJan2019CES2019590360-230x142.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5 class="listings-article-title"><a title="AMD allocates Blighty fewer than 100 Radeon 7 GPUs, claims retailer" href="/inquirer/news/3070589/amd-allocates-blighty-fewer-than-100-radeon-7-gpus-claims-retailer">AMD allocates Blighty fewer than 100 Radeon 7 GPUs, claims retailer</a></h5>
<p class="section-story">
Backs up earlier rumours of &#39;strictly limited&#39; quantities at launch
</p>
<ul class="article-meta-details">
<li>
<a class="inquirer-link" href="/category/hardware/graphics/">Graphics</a>
</li>
<li>
<time datetime="2019-02-06" itemprop="datePublished">
06 February 2019
</time>
</li>
</ul>
</div>
</article>
</div>
</section>


<section class="taboola-content" id="taboola-below-article-thumbnails">
<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
		        window._taboola = window._taboola || [];
		        _taboola.push({
		        mode: 'thumbnails-rd-a',
		        container: 'taboola-below-article-thumbnails',
		        placement: 'Below Article Thumbnails',
		        target_type: 'mix'
		        });
		    </script>
</section>
<div id="rdm-above-comments"></div>
<div id="disqus_thread"></div>
<script>

/**
*  RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
*  LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables*/
var disqus_config = function () {
this.page.url = 'http://www.theinquirer.net/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament';  // Replace PAGE_URL with your page's canonical URL variable
this.page.identifier = '/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament'; // Replace PAGE_IDENTIFIER with your page's unique identifier variable
};

(function() { // DON'T EDIT BELOW THIS LINE
var d = document, s = d.createElement('script');
s.src = '//theinq.disqus.com/embed.js'; // Replace SITE_SHORTNAME with your site’s shortname
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<div class="scrollup">
Back to Top
</div>
</div>
<div role="complementary" class="sidebar">
<div id="rdm-rhc-top" class="ad-slot"></div>

<section class="popular-articles">
<header class="related-listings-header">
<h4 itemprop="name">Most read</h4>
</header>
<div class="section group">
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3070503/google-now-pays-more-in-eu-fines-than-it-does-in-taxes"><img title="Google now pays more in EU fines than it does in taxes" alt="Google now pays more in EU fines than it does in taxes" src="/w-images/8394cea6-6eb1-41f5-8d84-0d73b12f0f60/0/googlelogoheadquarterssignsearchengineseo-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Google now pays more in EU fines than it does in taxes" href="/inquirer/news/3070503/google-now-pays-more-in-eu-fines-than-it-does-in-taxes">Google now pays more in EU fines than it does in taxes</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3030399/galaxy-s10-release-date-specs-price-pearl-white-model-image"><img title="Galaxy S10 release date, price and specs: &#39;Pearl white&#39; model exposed in latest leak" alt="Galaxy S10 release date, price and specs: &#39;Pearl white&#39; model exposed in latest leak" src="/w-images/dcb2b643-59ca-4d7c-a50f-4f46d564ce56/2/GalaxyS10-140x87.png" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Galaxy S10 release date, price and specs: &#39;Pearl white&#39; model exposed in latest leak" href="/inquirer/news/3030399/galaxy-s10-release-date-specs-price-pearl-white-model-image">Galaxy S10 release date, price and specs: &#39;Pearl white&#39; model exposed in latest leak</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3064540/galaxy-note-10-release-date-specs-price-camera-equipped-s-pen-leak"><img title="Galaxy Note 10 could avoid punch-hole with camera-equipped S Pen" alt="Galaxy Note 10 could avoid punch-hole with camera-equipped S Pen" src="/w-images/5a8b7095-5980-40a0-801b-31ced3da173f/3/SamsungGalaxyNote9Aug2018590360-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Galaxy Note 10 could avoid punch-hole with camera-equipped S Pen" href="/inquirer/news/3064540/galaxy-note-10-release-date-specs-price-camera-equipped-s-pen-leak">Galaxy Note 10 could avoid punch-hole with camera-equipped S Pen</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3070589/amd-allocates-blighty-fewer-than-100-radeon-7-gpus-claims-retailer"><img title="AMD allocates Blighty fewer than 100 Radeon 7 GPUs, claims retailer" alt="AMD allocates Blighty fewer than 100 Radeon 7 GPUs, claims retailer" src="/w-images/9c5cc219-eb85-4c51-abb6-2d3dcda3879f/2/AMDRadeonVIIJan2019CES2019590360-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="AMD allocates Blighty fewer than 100 Radeon 7 GPUs, claims retailer" href="/inquirer/news/3070589/amd-allocates-blighty-fewer-than-100-radeon-7-gpus-claims-retailer">AMD allocates Blighty fewer than 100 Radeon 7 GPUs, claims retailer</a>
</h5>
</div>
</article>
<article class="col span_1_of_4">
<div class="image-text-group-a">
<a href="/inquirer/news/3070532/windows-7-extended-support-pricing"><img title="Microsoft fixes pricing for Windows 7 extended support" alt="Microsoft fixes pricing for Windows 7 extended support" src="/w-images/f0750324-7537-4583-ba78-3b8d47ee7541/4/lengoodman-140x87.jpg" /></a>
</div>
<div class="image-text-group-b">
<h5> <a title="Microsoft fixes pricing for Windows 7 extended support" href="/inquirer/news/3070532/windows-7-extended-support-pricing">Microsoft fixes pricing for Windows 7 extended support</a>
</h5>
</div>
</article>
</div>
</section>

<div id="rdm-rhc-bottom" class="ad-slot"></div>
</div>
</main>
</div>
</div>
<aside class="content">
<div class="content-inner content-full-width">
<div class="main-content">
<div id="rdm-above-footer" class="ad-slot-full"></div>
</div>
</div>
</aside>
<footer class="main-footer">
<div class="main-footer-content main-footer-links">
<div class="main-footer-content-inner content-width">
<ul class="main-footer-nav">
<li class="menu-title"><a title="" href="https://www.theinquirer.net/static/aboutus">Contact</a></li>
<li class="menu-title"><a title="" href="http://btgmarketingsolutions.incisivemedia.com/">Marketing solutions</a></li>
<li class="menu-title"><a title="" href="http://www.enterpriseitevents.com/">Enterprise IT Events</a></li>
<li class="menu-title"><a title="" href="http://www.incisivemedia.com/our-story/" target="_blank" rel="noopener noreferrer">About Incisive Media</a></li>
<li class="menu-title"><a title="" href="http://www.incisivemedia.com/terms-and-conditions/" target="_blank" rel="noopener noreferrer">Terms &amp; conditions</a></li>
<li class="menu-title"><a title="" href="http://www.incisivemedia.com/privacy-policy/" target="_blank" rel="noopener noreferrer">Privacy policy</a></li>
</ul>
<ul class="footer-tools-content main-footer-align-right">
<li>
<div class="nav-tools rss-icon">
<a href="//www.theinquirer.net/static/rss" target="_blank">RSS</a>
</div>
</li>
<li>
<div class="nav-tools twitter-icon">
<a href="//twitter.com/INQ" target="_blank">Twitter</a>
</div>
</li>
<li>
<div class="nav-tools linkedin">
<a href="//www.linkedin.com/showcase/the-inquirer" target="_blank">LinkedIn</a>
</div>
</li>
<li>
<div class="nav-tools newsletters">
<a href="http://email.theinquirer.net/k/Incisive-Business/inq_nlsuf" target="_blank">Newsletters</a>
</div>
</li>
<li>
<div class="nav-tools facebook-icon">
<a href="//www.facebook.com/pages/The-Inquirer/30395818327" target="_blank">Facebook</a>
</div>
</li>
<li>
<div class="nav-tools gplus-icon">
<a href="//plus.google.com/+TheinquirerNetUK" target="_blank">Google+</a>
</div>
</li>
<li>
<div class="nav-tools youtube">
<a href="//www.youtube.com/theinquirer" target="_blank">YouTube</a>
</div>
</li>
</ul>
</div>
</div>
<div class="main-footer-content main-footer-copyright">
<div class="main-footer-content-inner content-width">
<div class="incisivemedia-footer">
<p class="corp-logo" style="float: left; padding: 20px 10px 0px 5px;"><a title="Incisive Media" href="https://www.incisivemedia.com/" target="_blank" rel="noopener noreferrer"><img src="//assets.incisivemedia.com/production/global/images/im_logo_white.png" width="150" height="38" /></a></p>
<p class="copyright-full">&copy; Incisive Business Media (IP) Limited, Published by Incisive Business Media Limited, New London House, 172 Drury Lane, London WC2B 5QR, registered in England and Wales with company registration numbers 09177174 &amp; 09178013</p>
</div>
<div class="incisivemedia-accreditation">
<div class="accredit-text"><a href="http://www.incisivemedia.com/accreditations" target="_blank" rel="noopener noreferrer">Digital publisher of the year</a></div>
<div class="accreditation-logos"><span class="screen-reader-text">Digital publisher of the year 2010, 2013, 2016 &amp; 2017</span></div>

<script defer="defer" src="//get.s-onetag.com/c80c8815-1563-4bcb-9219-e5a9f57282c0/tag.min.js" async=""></script>
</div>
</div>
</div>
</footer>
</div>
<script src="/javascripts/cookie.js"></script>
<script type="text/javascript">
	  jQuery(document).ready(function() {
	    if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
		var userlogin_path=location.pathname;
		if(userlogin_path == "/userlogin"){
		$("span#login_error_message_header").html(getCookie("series_token_error_message").replace(/\+/g, " ")).show();
		deleteCookie("series_token_error_message");
		}}});
		 jQuery(document).ready(function() {
		$("#userlogin .btn.login").on("click",function(){
		$("span#login_error_message_header").html("").hide();
		})});
	</script>
<script type="text/javascript">
	  jQuery(document).ready(function() {
	      if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
	      if(getCookie("series_token_error_message").match("articles$") !=null){
	   $("span#login_error_message_teaser").html(getCookie("series_token_error_message").replace(/\+/g, " ").replace(/\w+$/,'')).show();
	   deleteCookie("series_token_error_message");
	   }
	   }
	   });
	    jQuery(document).ready(function() {
	   $("#login_barrier .login_submit").on("click",function(){
	   $("span#login_error_message_teaser").html("").hide();
	   });});
	</script>
<script src="//assets.theinquirer.net/cdn/inq/scripts/scripts.js"></script>
<script src="/javascripts/KRESearch.js"></script>
<script type="text/javascript">
	    jQuery(document).ready(function() {
	    	$("#login").hover(function(){
		       $(".login-offset").hide();
			});
	    	 setTimeout(function(){ 
	    	 	jQuery("#register,#login,#follow,#free-trial").show();
				if(getCookie("logged_in") == "false"){
						jQuery("#register,#login,#follow,#free-trial").show();
					    jQuery("#user").hide();
				}else if(getCookie("logged_in") == "true"  || getCookie("logged_in") == "expired"|| getCookie("logged_in") == null){
						if(getCookie("first_name")!= null && getCookie("first_name")!="" && getCookie("subc")!=""){
							$("#user,#follow").show();
					        $("#register,#login,#free-trial").hide();
					        jQuery(".user-info").html('My account');
							if(getCookie("institutional_login") == "true"){
								if(getCookie("individual_login") == "true"){
									$(".individual").show();
									$('.institutional').hide();
									$(".user-info").html('My account');
									$("#user").removeClass("main-top-institution");
								}else{
									$(".individual").hide();
									$(".user-info").html('Welcome');
									$("#user").addClass("main-top-institution");
								}
							}else{
									$(".individual").show();
									$("#user").removeClass("main-top-institution");
							}
						}else{
								jQuery.ajax({
		                        type : 'GET',
		                        dataType : 'html',
		                        beforeSend : function(xhr) {
		                            xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'))
		                        },
		                        url : '/user_info',
		                        success : function(data) {
		                            if(getCookie("logged_in") == "true" || getCookie("logged_in") == "expired" ){
		                                if(getCookie("first_name")!= null && getCookie("subc")!= null && getCookie("first_name")!="" && getCookie("subc")!=""){
											$("#user,#follow").show();
					        				$("#register,#login,#free-trial").hide();
					        				jQuery(".user-info").html('My account');
											if(getCookie("institutional_login") == "true"){
												if(getCookie("individual_login") == "true"){
													$(".individual").show();
													$('.institutional').hide();
													$(".user-info").html('My account');
													$("#user").removeClass("main-top-institution");
												}else{
													$(".individual").hide();
													$('.institutional').show();
													$(".user-info").html('Welcome');
													$("#user").addClass("main-top-institution");
												}
											}else{
													$(".individual").show();
													$("#user").removeClass("main-top-institution");
											}
		                                }
		                            }
		                           else{
									   $("#register,#login,#follow,#free-trial").show();
								if(getCookie("series_token_error_message")!=null && getCookie("series_token_error_message") !=""){
									   var userlogin_path=location.pathname;
									   if(userlogin_path != "/userlogin" &&  (getCookie("series_token_error_message").match("articles$") == null)){
									   location.pathname="/userlogin";
									   }}
									}
		                        }
		                    });
						}
				}
					}, 2000);
			$("#user").hover(function(event){
			   event.preventDefault();
			   if(getCookie("institutional_login") == "true"){
					if(getCookie("individual_login") == "true"){
						$(".individual").show();
						$('.institutional').hide();
					}else{
						$(".individual").hide();
						$('.institutional').show();
					}
				}
			});
		});
	</script>
<script type="text/javascript">
		/* article teaser csrf token */
		$(function(){
			 jQuery.ajax({
            url : '/article_teaser_login',
            beforeSend : function(xhr) {
                xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
                $( "#export_loaders" ).show();              
            },
            success : function(data) {
            	$( "#export_loaders" ).hide();
                $(".art_teaser").html(data);
            }
        });
		});
	</script>
<script type="text/javascript">
/*script for login */

jQuery(document).on('click', '.login_form_submit.login_submit', function(event) {
	event.preventDefault();
    jQuery.ajax({
        url : '/wps/authentication/verify_subscription_login',
        type : 'POST',
        data : jQuery("#userloginpop").serialize(),
        dataType : 'json',
        beforeSend : function(xhr) {
            xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
             $("#follow,#register,#login,#free-trial").hide();
              $( "#export_loaders" ).show();
        },
        success : function(data) {
            if (data.status == "true") {
            	$( "#export_loaders" ).hide();
            	$("#follow,#user").show();
                location.reload();
            } else {
            	jQuery("#register,#login,#follow,#free-trial").show();
            	$( "#export_loaders" ).hide();
                jQuery('#login_error_message_header,#login_error_message_teaser').show();
                jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
            }
        }
    });

});
jQuery(document).on('click', '.btn.login', function(event) {
	event.preventDefault();
    jQuery.ajax({
        url : '/wps/authentication/verify_subscription_login',
        type : 'POST',
        data : jQuery("#userlogin").serialize(),
        dataType : 'json',
        beforeSend : function(xhr) {
            xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
              $( "#export_loaders" ).show();
        },
        success : function(data) {
            if (data.status == "true") {
            	$( "#export_loaders" ).hide();
            	var a=$(".cls_redirect").attr("value");
            	location.href=a;
            } else {
            	jQuery("#register,#login,#follow,#free-trial").show();
            	$( "#export_loaders" ).hide();
                jQuery('#login_error_message_header,#login_error_message_teaser').show();
                jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
            }
        }
    });

});
jQuery(document).on('click', '.submit_style.login_submit', function(event) {
    event.preventDefault();

    jQuery.ajax({
        url : '/wps/authentication/verify_subscription_login',
        type : 'POST',
        data : jQuery('#login_barrier').serialize(),
        dataType : 'json',
        beforeSend : function(xhr) {
            xhr.setRequestHeader('X-CSRF-Token', jQuery('meta[name="csrf-token"]').attr('content'));
             setTimeout(function(){ 
              $( "#export_loaders" ).show();
             }, 1000);
        },
        success : function(data) {
            if (data.status == "true") {
            	$( "#export_loaders" ).hide();
                location.reload()
            } else {
               jQuery("#register,#login,#follow,#free-trial").show();
               $( "#export_loaders" ).hide();
               jQuery('#login_error_message_header,#login_error_message_teaser').show();
               jQuery('#login_error_message_header,#login_error_message_teaser').text(data.message);
            }
        }
    });
});
</script>
<script type="text/javascript">
	    /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
	    var disqus_shortname = 'theinq'; // required: replace example with your forum shortname
	 var disqus_identifier = "/inquirer/news/3070617/huawei-refutes-uk-govs-spying-concerns-in-open-letter-to-parliament";
	    /* * * DON'T EDIT BELOW THIS LINE * * */
	    (function () {
	        var s = document.createElement('script'); 
	        s.async = true;
	        s.type = 'text/javascript';
	        s.src = '//theinq.disqus.com/count.js';
	        (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
	    }());
</script>

<script type="text/javascript" src='//assets.theinquirer.net/javascript/live/the_inquirer/javascript-the_inquirer.body.min.js'></script>

<script type="text/javascript">
   	 window._taboola = window._taboola || [];
  	_taboola.push({flush: true});
	</script>
<script id="dsq-count-scr" src="//theinq.disqus.com/count.js" async></script> 
</body>
</html>
